summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrad Culwell2024-03-20 15:59:54 -0500
committerBrad Culwell2024-03-20 15:59:54 -0500
commita865b53ff31d3522784c9765df6bda92eedfbb9a (patch)
tree736292599705002dcbfb73e72e1f78190683b805
downloadaur-a865b53ff31d3522784c9765df6bda92eedfbb9a.tar.gz
v0.6.3-1
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD30
-rw-r--r--makefile7
4 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3db7a6657c2d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = nyaa-bin
+ pkgdesc = A tui tool for browsing and downloading torrents from nyaa.si
+ pkgver = 0.6.3
+ pkgrel = 1
+ url = https://github.com/Beastwick18/nyaa/
+ arch = x86_64
+ license = GPL-3.0-or-later
+ provides = nyaa
+ conflicts = nyaa
+ source_x86_64 = nyaa-bin-0.6.3::https://github.com/Beastwick18/nyaa/releases/download/v0.6.3/nyaa-0.6.3-x86_64-unknown-linux-gnu
+ b2sums_x86_64 = 0cd662a445407d3d938f2081c9891ee35a3d9fd0b37e6bed322f6c9f906e663272e8cbf17223f967b2418964c293f8f7e469a54467af2cb8e1d40cebb984ab7f
+
+pkgname = nyaa-bin
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..b8d8873dff4d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*
+!.gitignore
+!PKGBUILD
+!.SRCINFO
+!makefile
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bc3e4482c92d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+pkgname=nyaa-bin
+pkgver=0.6.3
+pkgrel=1
+pkgdesc="A tui tool for browsing and downloading torrents from nyaa.si"
+url='https://github.com/Beastwick18/nyaa/'
+source_x86_64=("$pkgname-$pkgver::https://github.com/Beastwick18/nyaa/releases/download/v$pkgver/nyaa-$pkgver-x86_64-unknown-linux-gnu")
+# source_aarch64=("")
+# source_armv7h=("")
+# arch=('x86_64' 'aarch64' 'armv7h')
+arch=('x86_64')
+license=('GPL-3.0-or-later')
+# depends=('git' 'pacman' 'libalpm.so>=14-64')
+conflicts=('nyaa')
+provides=('nyaa')
+b2sums_x86_64=('0cd662a445407d3d938f2081c9891ee35a3d9fd0b37e6bed322f6c9f906e663272e8cbf17223f967b2418964c293f8f7e469a54467af2cb8e1d40cebb984ab7f')
+
+package() {
+ cd "$srcdir/"
+
+ install -Dm755 "$pkgname-$pkgver" "${pkgdir}/usr/bin/nyaa"
+
+ # install -Dm644 man/nyaa.8 "$pkgdir/usr/share/man/man8/nyaa.8"
+ # install -Dm644 man/nyaa.conf.5 "$pkgdir/usr/share/man/man5/nyaa.conf.5"
+
+ # install -Dm644 completions/bash "${pkgdir}/usr/share/bash-completion/completions/nyaa.bash"
+ # install -Dm644 completions/fish "${pkgdir}/usr/share/fish/vendor_completions.d/nyaa.fish"
+ # install -Dm644 completions/zsh "${pkgdir}/usr/share/zsh/site-functions/_nyaa"
+
+ # cp -r locale "$pkgdir/usr/share/"
+}
diff --git a/makefile b/makefile
new file mode 100644
index 000000000000..dad31b472a10
--- /dev/null
+++ b/makefile
@@ -0,0 +1,7 @@
+.phony: pkg src
+
+src: PKGBUILD
+ makepkg --printsrcinfo > .SRCINFO
+
+pkg:
+ makepkg -Asc