summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJelle van der Waa2023-03-26 15:31:11 +0200
committerJelle van der Waa2023-03-26 15:31:11 +0200
commit7f329fa6e11c708d8af4783464c548d3f2de9e60 (patch)
treef498b983b1bef4258f0218e07ac8baa1a6dc7d88
parente0c330f84ffb866a157a4b7b214564c1a6b5f765 (diff)
downloadaur-7f329fa6e11c708d8af4783464c548d3f2de9e60.tar.gz
update to [extra] version
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD21
2 files changed, 15 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e125d1e1f4eb..4ec983dc2d23 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,19 @@
pkgbase = nyacc
pkgdesc = Not Yet Another Compiler Compiler
- pkgver = 0.99.2
+ pkgver = 1.05.1
pkgrel = 1
url = http://www.nongnu.org/nyacc
arch = any
license = GPL
license = LGPL
license = FDL
+ makedepends = guile
depends = guile
- source = http://download-mirror.savannah.gnu.org/releases/nyacc/nyacc-0.99.2.tar.gz
- source = http://download-mirror.savannah.gnu.org/releases/nyacc/nyacc-0.99.2.tar.gz.sig
+ depends = guile-bytestructures
+ source = http://download-mirror.savannah.gnu.org/releases/nyacc/nyacc-1.05.1.tar.gz
+ source = http://download-mirror.savannah.gnu.org/releases/nyacc/nyacc-1.05.1.tar.gz.sig
validpgpkeys = 7C9EDA8DCE5DC8AE2C675EC9EE4F2A40097B7C03
- sha256sums = f182d097b1e2d8a75a8d7c857171131f0361da3a9087096b768ffda4ecf6e3a7
+ sha256sums = c32042c1524646ba1a27b515203fab2240e6151fdb9e306e55b0154bbf7f63b2
sha256sums = SKIP
pkgname = nyacc
-
diff --git a/PKGBUILD b/PKGBUILD
index c834e561485b..43767cf9f655 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,27 @@
-# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+# Maintainer: Jelle van der Waa <jelle@archlinux.org>
+# Contributor: Stefan Husmann <stefan-husmann@t-online.de>
-pkgname=nyacc
-pkgver=0.99.2
+pkgname=nyacc
+pkgver=1.05.1
pkgrel=1
pkgdesc="Not Yet Another Compiler Compiler"
url="http://www.nongnu.org/nyacc"
arch=('any')
license=('GPL' 'LGPL' 'FDL')
-depends=('guile')
-makedepends=()
+depends=('guile' 'guile-bytestructures')
+makedepends=('guile')
source=("http://download-mirror.savannah.gnu.org/releases/nyacc/$pkgname-$pkgver.tar.gz"{,.sig})
-sha256sums=('f182d097b1e2d8a75a8d7c857171131f0361da3a9087096b768ffda4ecf6e3a7'
+sha256sums=('c32042c1524646ba1a27b515203fab2240e6151fdb9e306e55b0154bbf7f63b2'
'SKIP')
validpgpkeys=('7C9EDA8DCE5DC8AE2C675EC9EE4F2A40097B7C03') # Marc Wette
build() {
cd $pkgname-$pkgver
- GUILD=/usr/bin/guild ./configure
+ ./configure --prefix=/usr
make
}
package() {
cd $pkgname-$pkgver
- make SITE_SCM_DIR="$pkgdir"/usr/share/guile/2.2/ \
- SITE_SCM_GO_dir="$pkgdir"/usr/lib/guile/2.2/ccache install-srcs
- install -d "$pkgdir"/usr/share/doc/$pkgname
- cd doc/$pkgname
- cp nyacc*.{pdf,html} "$pkgdir"/usr/share/doc/$pkgname
+ make install DESTDIR=$pkgdir
}