summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefan Husmann2017-03-05 12:21:25 +0100
committerStefan Husmann2017-03-05 12:21:25 +0100
commitbe76867737b44c6592a9c33e77f821d3119d23fe (patch)
tree30b4837cc79b81f5b02b4d7bbeac432b9e0023ce
downloadaur-be76867737b44c6592a9c33e77f821d3119d23fe.tar.gz
initial upload
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD23
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f61e5bff5fa8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = nyacc
+ pkgdesc = Not Yet Another Compiler Compiler
+ pkgver = 0.76.5
+ pkgrel = 1
+ url = http://www.nongnu.org/nyacc
+ arch = any
+ license = GPL
+ license = LGPL
+ license = GFDL
+ depends = guile
+ source = https://download.savannah.gnu.org/releases/nyacc/nyacc-0.76.5.tar.gz
+ sha256sums = 8085fa68829eb49215786eb3a1f5b7e06944a10d3bedc78c9edf6a4dfbac78a2
+
+pkgname = nyacc
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b60dda5119ca
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+
+pkgname=nyacc
+pkgver=0.76.5
+pkgrel=1
+pkgdesc="Not Yet Another Compiler Compiler"
+url="http://www.nongnu.org/nyacc"
+arch=('any')
+license=('GPL' 'LGPL' 'GFDL')
+depends=('guile')
+makedepends=()
+source=(https://download.savannah.gnu.org/releases/nyacc/$pkgname-$pkgver.tar.gz)
+sha256sums=('8085fa68829eb49215786eb3a1f5b7e06944a10d3bedc78c9edf6a4dfbac78a2')
+
+prepare() {
+ cd $pkgname-$pkgver/module
+ sed 's+DIR=+DIR=$(DESTDIR)+' Makefile.nyacc > Makefile
+}
+
+package() {
+ cd $pkgname-$pkgver/module
+ make DESTDIR=$pkgdir install
+}