summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSophie 'Sharky' Schumann2019-04-18 23:10:54 +0200
committerSophie 'Sharky' Schumann2019-04-18 23:10:54 +0200
commit4db3fc817902cb0c3f1596e559417f64831abc27 (patch)
treeff8f33e9fcfa11781e64e1adf748aca9ac80c641
downloadaur-4db3fc817902cb0c3f1596e559417f64831abc27.tar.gz
init
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD42
2 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c2eadb76347c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = nyancoin-daemon
+ pkgdesc = NyanCoin daemon
+ pkgver = 1.3.2
+ pkgrel = 1
+ url = https://reddit.com/r/NyanCoins
+ arch = x86_64
+ arch = i686
+ arch = armv6h
+ arch = armv7h
+ arch = aarch64
+ license = MIT
+ makedepends = boost
+ depends = boost-libs
+ depends = libdb-4.8
+ depends = openssl
+ depends = miniupnpc
+ source = git+https://github.com/Nyancoins/nyancoin-client.git
+ md5sums = SKIP
+
+pkgname = nyancoin-daemon
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f483406c885c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Sophie 'Sharky' Schumann <sharky@sharky.pw>
+pkgname=nyancoin-daemon
+pkgver=1.3.2
+pkgrel=1
+epoch=
+pkgdesc="NyanCoin daemon"
+arch=('x86_64' 'i686' 'armv6h' 'armv7h' 'aarch64')
+url="https://reddit.com/r/NyanCoins"
+license=('MIT')
+groups=()
+depends=(boost-libs libdb-4.8 openssl miniupnpc)
+makedepends=(boost)
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("git+https://github.com/Nyancoins/nyancoin-client.git")
+noextract=()
+md5sums=(SKIP)
+validpgpkeys=()
+
+prepare() {
+ cd "nyancoin-client"
+
+}
+
+build() {
+ cd "nyancoin-client/src"
+ make -f makefile.unix RELEASE=1
+}
+
+package() {
+ cd "nyancoin-client/src"
+ mkdir "$pkgdir/usr/bin" -p
+ cp -v "nyancoind" "$pkgdir/usr/bin/"
+}
+