summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSophie 'Sharky' Schumann2019-04-18 23:12:46 +0200
committerSophie 'Sharky' Schumann2019-04-18 23:12:53 +0200
commitadabb47ba7417a93827a48af278e2795e24e1a07 (patch)
tree1662fab0629dfaac77756a43c18a515b0bf18092
downloadaur-adabb47ba7417a93827a48af278e2795e24e1a07.tar.gz
init
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD50
-rwxr-xr-xnyancoin-qt.desktop10
-rw-r--r--nyancoin-qt.pngbin0 -> 10112 bytes
4 files changed, 86 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..825aafdff1c2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = nyancoin-qt
+ pkgdesc = NyanCoin Qt5 wallet
+ pkgver = 1.3.2
+ pkgrel = 1
+ url = https://reddit.com/r/NyanCoins
+ arch = x86_64
+ arch = i686
+ arch = armv6h
+ arch = armv7h
+ arch = aarch64
+ license = MIT
+ makedepends = boost
+ depends = boost-libs
+ depends = libdb-4.8
+ depends = openssl
+ depends = miniupnpc
+ depends = qt5-base
+ source = git+https://github.com/Nyancoins/nyancoin-client.git
+ source = nyancoin-qt.desktop
+ source = nyancoin-qt.png
+ md5sums = SKIP
+ md5sums = f5ec718a29bcd8419c5aafe1b4e210b5
+ md5sums = 1a235ccadeff05eb3422027e3fb610ba
+
+pkgname = nyancoin-qt
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fcbb2ea79325
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Maintainer: Sophie 'Sharky' Schumann <sharky@sharky.pw>
+pkgname=nyancoin-qt
+pkgver=1.3.2
+pkgrel=1
+epoch=
+pkgdesc="NyanCoin Qt5 wallet"
+arch=('x86_64' 'i686' 'armv6h' 'armv7h' 'aarch64')
+url="https://reddit.com/r/NyanCoins"
+license=('MIT')
+groups=()
+depends=(boost-libs libdb-4.8 openssl miniupnpc qt5-base)
+makedepends=(boost)
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=(
+ "git+https://github.com/Nyancoins/nyancoin-client.git"
+ "nyancoin-qt.desktop"
+ "nyancoin-qt.png"
+)
+noextract=()
+md5sums=('SKIP'
+ 'f5ec718a29bcd8419c5aafe1b4e210b5'
+ '1a235ccadeff05eb3422027e3fb610ba')
+validpgpkeys=()
+
+build() {
+ cd "nyancoin-client"
+ qmake \
+ BDB_LIB_SUFFIX="" \
+ BDB_LIB_PATH="/opt/BerkeleyDB-4.8/lib" \
+ BDB_INCLUDE_PATH="/opt/BerkeleyDB-4.8/include"
+ make
+}
+
+package() {
+ cd "nyancoin-client"
+ mkdir "$pkgdir/usr/bin" -p
+ cp -v "Nyancoin-qt" "$pkgdir/usr/bin/"
+
+ install -Dm644 "$srcdir/$pkgname.desktop" "$pkgdir/usr/share/applications/$pkgname.desktop"
+ install -Dm644 "$srcdir/$pkgname.png" "$pkgdir/usr/share/pixmaps/$pkgname.png"
+}
+
diff --git a/nyancoin-qt.desktop b/nyancoin-qt.desktop
new file mode 100755
index 000000000000..0db9698cca33
--- /dev/null
+++ b/nyancoin-qt.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Version=1.3.2
+Type=Application
+Name=Nyancoin
+Comment=NyanCoin wallet
+Exec=Nyancoin-qt
+Icon=nyancoin-qt
+Terminal=false
+StartupNotify=false
+Categories=Network;Finance;Qt
diff --git a/nyancoin-qt.png b/nyancoin-qt.png
new file mode 100644
index 000000000000..04b3e3d46671
--- /dev/null
+++ b/nyancoin-qt.png
Binary files differ