summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfusion8092016-06-04 14:24:35 +1000
committerfusion8092016-06-04 14:24:35 +1000
commitb48a2c166f6500d632faba2e3dd25f1ef75ae923 (patch)
tree9411bcb89f575ce09f5d814f908f16cb11edad71
parentbc43eb88d5d4c6771bb96d6000e4b34e21d66fb7 (diff)
downloadaur-b48a2c166f6500d632faba2e3dd25f1ef75ae923.tar.gz
Updating
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD9
-rw-r--r--nyaovim.desktop11
3 files changed, 21 insertions, 3 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..fd93f71fc1ed
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg
+src
+*.xz
+*.tgz
diff --git a/PKGBUILD b/PKGBUILD
index d4b50c3f6803..28cac5210a29 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,18 +2,21 @@
pkgname=nyaovim
pkgver=0.0.19
-pkgrel=1
+pkgrel=2
pkgdesc="Neovim frontend built on Electron"
arch=(any)
url="https://www.npmjs.com/package/nyaovim"
license=("MIT")
depends=('nodejs' 'libnotify')
makedepends=('npm')
-source=("http://registry.npmjs.org/$pkgname/-/$pkgname-$pkgver.tgz")
-sha256sums=('cd29cee59ef904da12bb3789b391cc28fac22a7936f205d07ecdea6ee53324e0')
+source=("http://registry.npmjs.org/$pkgname/-/$pkgname-$pkgver.tgz"
+"$pkgname.desktop")
+sha256sums=('cd29cee59ef904da12bb3789b391cc28fac22a7936f205d07ecdea6ee53324e0'
+ '5dd8dc38f332ee035743f61cae390b50a5c5b94c6a7a448cd4afe28042d0712c')
noextract=("$pkgname-$pkgver.tgz")
package() {
npm install -g --user root --prefix "$pkgdir/usr" "$srcdir/$pkgname-$pkgver.tgz"
rm -r "$pkgdir/usr/etc"
+ install -Dm644 $srcdir/$pkgname.desktop "$pkgdir/usr/share/applications/nyaovim.desktop"
}
diff --git a/nyaovim.desktop b/nyaovim.desktop
new file mode 100644
index 000000000000..3e2fc2c8a142
--- /dev/null
+++ b/nyaovim.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Name=Nyaovim
+GenericName=Nyaovim
+Comment=Web-enhanced Extensible Neovim Frontend
+Exec=nyaovim
+Icon=/usr/lib/node_modules/nyaovim/resources/icon/nyaovim-logo.png
+Terminal=false
+Type=Application
+Categories=Development;TextEditor;
+MimeType=application/javascript;application/json;application/postscript;application/x-csh;application/x-desktop;application/x-httpd-eruby;application/x-httpd-php;application/x-httpd-php3;application/x-httpd-php4;application/x-httpd-php5;application/x-latex;application/x-msdos-program;application/x-ruby;application/x-sh;application/x-shellscript;application/x-sql;application/x-tcl;application/x-tex;application/xhtml+xml;application/xml;application/xml-dtd;application/xslt+xml;text/css;text/csv;text/html;text/plain;text/xml;text/xml-dtd;text/x-asm;text/x-bibtex;text/x-boo;text/x-c++;text/x-c++hdr;text/x-c++src;text/x-c;text/x-chdr;text/x-csh;text/x-csrc;text/x-dsrc;text/x-diff;text/x-eiffel;text/x-fortran;text/x-go;text/x-haskell;text/x-java;text/x-java-source;text/x-lua;text/x-makefile;text/x-markdown;text/x-objc;text/x-pascal;text/x-perl;text/x-php;text/x-python;text/x-ruby;text/x-scala;text/x-scheme;text/x-sh;text/x-tcl;text/x-tex;text/x-vala;text/yaml;inode/directory;
+