summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorD. Can Celasun2017-04-16 01:05:03 +0200
committerD. Can Celasun2017-04-16 01:05:03 +0200
commit44572778b8fa4ebd6f8a473961b57bf1c7004eee (patch)
tree48a360d90c5e84d3a23dec6e8ae439b6a3beb504
downloadaur-44572778b8fa4ebd6f8a473961b57bf1c7004eee.tar.gz
Rename nylas-mail to nylas-mail-git
-rw-r--r--.SRCINFO35
-rw-r--r--PKGBUILD65
-rw-r--r--nylas-mail.desktop11
-rw-r--r--nylas-mail.install10
-rw-r--r--nylas-mail.pngbin0 -> 164504 bytes
5 files changed, 121 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4cc28e5e4b35
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,35 @@
+# Generated by mksrcinfo v8
+# Tue Apr 11 06:19:59 UTC 2017
+pkgbase = nylas-mail
+ pkgdesc = Nylas Mail: A new mail client for Linux, Mac and Windows, built on the modern web and designed to be extended. (formerly N1)
+ pkgver = 1.0.26.48.g0a100dd7
+ pkgrel = 1
+ epoch = 1
+ url = https://nylas.com
+ install = nylas-mail.install
+ arch = x86_64
+ license = MIT
+ makedepends = nvm
+ makedepends = grunt-cli
+ depends = gtk2
+ depends = libgnome-keyring
+ depends = gnome-keyring
+ depends = desktop-file-utils
+ depends = python2
+ depends = gconf
+ depends = nodejs
+ depends = libnotify
+ depends = libxtst
+ depends = nss
+ depends = alsa-lib
+ depends = libxss
+ conflicts = nylas-mail-bin
+ source = git://github.com/nylas/nylas-mail.git
+ source = nylas-mail.desktop
+ source = nylas-mail.png
+ md5sums = SKIP
+ md5sums = 267b600b1fcddc876b829c8579437770
+ md5sums = abb3ea88173fe5dd12dab8c3737dc087
+
+pkgname = nylas-mail
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b9ddd996d333
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,65 @@
+# Maintainer: D. Can Celasun <dcelasun[at]gmail[dot]com>
+pkgname=nylas-mail-git
+_pkgname=nylas-mail
+pkgver=1.0.26.49.g52452d6d
+pkgrel=1
+epoch=1 # Versions numbers went from 2.x to 1.x during the N1 -> Mail switch, so this is necessary
+pkgdesc="Nylas Mail: A new mail client for Linux, Mac and Windows, built on the modern web and designed to be extended. (formerly N1, git version)"
+arch=('x86_64')
+url="https://nylas.com"
+license=('MIT')
+makedepends=('nvm' 'grunt-cli')
+depends=('gtk2' 'libgnome-keyring' 'gnome-keyring' 'desktop-file-utils' 'python2' 'gconf' 'nodejs' 'libnotify' 'libxtst' 'nss' 'alsa-lib' 'libxss')
+conflicts=('nylas-mail-bin')
+source=('git://github.com/nylas/nylas-mail.git'
+ ${_pkgname}.desktop
+ ${_pkgname}.png)
+md5sums=('SKIP'
+ '267b600b1fcddc876b829c8579437770'
+ 'abb3ea88173fe5dd12dab8c3737dc087')
+install=${_pkgname}.install
+pkgver() {
+ cd ${_pkgname}
+ git describe --always | sed 's|-|.|g'
+}
+build() {
+ export NVM_DIR="${srcdir}/.nvm"
+ source /usr/share/nvm/nvm.sh
+ source /usr/share/nvm/install-nvm-exec
+ unset NPM_CONFIG_PREFIX
+ nvm install v6.9.1
+ nvm use --delete-prefix v6.9.1
+
+ cd "${srcdir}/${_pkgname}"
+ ./script/bootstrap
+ npm install grunt
+ ./script/grunt build
+}
+package() {
+ mkdir -p "${pkgdir}"/usr/share/${_pkgname}
+ mkdir -p "${pkgdir}"/usr/bin
+ mkdir -p "${pkgdir}"/usr/share/licenses/${_pkgname}
+ mkdir -p "${pkgdir}"/usr/share/pixmaps
+ mkdir -p "${pkgdir}"/usr/share/applications
+
+ cp "${srcdir}"/${_pkgname}.png "${pkgdir}"/usr/share/pixmaps
+ cp "${srcdir}"/${_pkgname}.desktop "${pkgdir}"/usr/share/applications
+ cp "${srcdir}"/${_pkgname}/dist/nylas-linux-x64/* "${pkgdir}"/usr/share/${_pkgname} -R
+
+ # Remove references to $srcdir from generated package.json files
+ # This doesn't remove all references, but still better than nothing.
+ find . -name "package.json" -exec sed -i '/_where/d' {} \;
+
+ cd "${pkgdir}"
+ find -name '*.py' -exec sed -i 's|^#!/usr/bin/env python\s*$|#!/usr/bin/env python2|' {} \;
+ find -name '*.py' -exec sed -i 's|^#!/usr/bin/python\s*$|#!/usr/bin/python2|' {} \;
+
+ chmod 755 "${pkgdir}"/usr/share/${_pkgname}/nylas
+ chmod 755 "${pkgdir}"/usr/share/${_pkgname}/resources/apm/bin/{node,apm}
+
+ mkdir -p "${pkgdir}"/usr/share/licenses/${_pkgname}/
+
+ rm -rf "${pkgdir}/usr/bin/nylas"
+ ln -s /usr/share/${_pkgname}/nylas "${pkgdir}"/usr/bin/nylas
+ ln -s /usr/share/${_pkgname}/LICENSE "${pkgdir}"/usr/share/licenses/${_pkgname}/LICENSE
+}
diff --git a/nylas-mail.desktop b/nylas-mail.desktop
new file mode 100644
index 000000000000..3516a457b1f4
--- /dev/null
+++ b/nylas-mail.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Name=Nylas Mail
+Comment=The best email app for people and teams at work
+GenericName=Nylas Mail
+Exec=/usr/bin/nylas %U
+Icon=nylas-mail
+Type=Application
+StartupNotify=true
+StartupWMClass=Nylas Mail
+Categories=GNOME;GTK;Network;Email;Utility;Development;
+MimeType=text/plain;x-scheme-handler/mailto;x-scheme-handler/nylas;
diff --git a/nylas-mail.install b/nylas-mail.install
new file mode 100644
index 000000000000..54315b8833ce
--- /dev/null
+++ b/nylas-mail.install
@@ -0,0 +1,10 @@
+post_install() {
+ gtk-update-icon-cache /usr/share/icons/hicolor > /dev/null 2>&1
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ gtk-update-icon-cache /usr/share/icons/hicolor > /dev/null 2>&1
+ update-desktop-database -q
+}
+
diff --git a/nylas-mail.png b/nylas-mail.png
new file mode 100644
index 000000000000..a69dbaaff490
--- /dev/null
+++ b/nylas-mail.png
Binary files differ