summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcrabvk2021-12-22 05:26:38 +0500
committercrabvk2021-12-22 05:26:38 +0500
commit3270303a4e9fe26ac264ea6736e542883535e964 (patch)
tree901905787193288c7cd5c6420a1d998d05830ad4
downloadaur-3270303a4e9fe26ac264ea6736e542883535e964.tar.gz
Nym wallet version 0.12.0
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD31
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dd6da0643243
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = nym-wallet
+ pkgdesc = The next generation of privacy infrastructure (Nym wallet)
+ pkgver = 0.12.0
+ pkgrel = 1
+ url = https://nymtech.net/
+ arch = x86_64
+ license = MIT
+ makedepends = cargo
+ makedepends = nodejs
+ makedepends = yarn
+ makedepends = patchelf
+ depends = openssl
+ depends = pango
+ depends = gdk-pixbuf2
+ depends = webkit2gtk
+ depends = librsvg
+ source = https://github.com/nymtech/nym/archive/refs/tags/v0.12.0.tar.gz
+ sha512sums = 29e8fe735d9b60b1a0207e1591e08aff4d51fd4e82aaf76898aedbfacae1dbf68c81230a9fbb24385db91f72a0d870bb5bb1f7e0e15c13e6425302b9492a8235
+
+pkgname = nym-wallet
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3169615c29e8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Vyacheslav Konovalov <🦀vk@protonmail.com>
+
+pkgname=nym-wallet
+pkgver=0.12.0
+pkgrel=1
+pkgdesc='The next generation of privacy infrastructure (Nym wallet)'
+arch=('x86_64')
+url='https://nymtech.net/'
+license=('MIT')
+depends=('openssl' 'pango' 'gdk-pixbuf2' 'webkit2gtk' 'librsvg')
+makedepends=('cargo' 'nodejs' 'yarn' 'patchelf')
+source=("https://github.com/nymtech/nym/archive/refs/tags/v$pkgver.tar.gz")
+sha512sums=('29e8fe735d9b60b1a0207e1591e08aff4d51fd4e82aaf76898aedbfacae1dbf68c81230a9fbb24385db91f72a0d870bb5bb1f7e0e15c13e6425302b9492a8235')
+
+prepare() {
+ sed -ri 's/"targets": .+,/"targets": ["deb"],/' nym-$pkgver/nym-wallet/src-tauri/tauri.conf.json
+}
+
+build() {
+ cd nym-$pkgver/nym-wallet
+
+ yarn install --cache-folder "$srcdir/yarn-cache"
+ yarn build
+}
+
+package() {
+ cd nym-$pkgver
+
+ cp -r "nym-wallet/target/release/bundle/deb/nym-wallet_${pkgver}_amd64/data/usr" "$pkgdir/"
+ install -Dm644 LICENSES/MIT.txt "$pkgdir/usr/share/licenses/nym-wallet/LICENSE"
+}