summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRadeox2021-10-07 15:29:51 +0200
committerRadeox2021-10-07 15:29:51 +0200
commit3534d582fc3d60c07f97e4e6a7dc5453d6755d5b (patch)
tree970a4b26ec4f6df49a82402e17ec7ccbfebf78c8
parent8debf1cf6a1389b3be87957111acde194d8c7a68 (diff)
downloadaur-3534d582fc3d60c07f97e4e6a7dc5453d6755d5b.tar.gz
Release 2.2
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD44
-rw-r--r--nyrna.desktop10
-rw-r--r--nyrna.pngbin6988 -> 0 bytes
5 files changed, 35 insertions, 43 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ef162fc06463..7a2c215ac55b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,17 @@
pkgbase = nyrna
- pkgdesc = Simple program to pause games & applications
- pkgver = 1.3
+ pkgdesc = Suspend games and applications at any time and resume whenever you wish
+ pkgver = 2.2.0
pkgrel = 1
url = https://github.com/Merrit/nyrna
arch = x86_64
- license = GPL3 or any later version
- makedepends = go
- makedepends = gcc
- makedepends = libxkbcommon-x11
+ license = GPL3
+ makedepends = flutter
depends = gtk3
depends = libappindicator-gtk3
depends = zenity
- source = nyrna-1.3.tar.gz::https://github.com/Merrit/nyrna/archive/v1.3.tar.gz
- sha256sums = 7137706aaf09cc49acf8b5971e614871cd7d370748c415fd542c68cb1f2b1b26
+ depends = wmctrl
+ depends = xdotool
+ source = nyrna-2.2.0.tar.gz::https://github.com/Merrit/nyrna/archive/refs/tags/v2.2.0.tar.gz
+ sha256sums = 88a288a56a60c5a9262da330fff44ba6f09e3a5801105f247a96f4b3345850eb
pkgname = nyrna
-
diff --git a/.gitignore b/.gitignore
index 723b9b553bb7..945cab1fa908 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,5 +1,8 @@
# KDE's Dolphin
.directory
-nyrna*.tar.gz
-README \ No newline at end of file
+nyrna*.tar.*
+README
+
+pkg
+src
diff --git a/PKGBUILD b/PKGBUILD
index 01f4030b0d81..3be9bab400e5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,37 +1,37 @@
-# Maintainer: Kristen McWilliam <merritt_public at outlook dot com>
+# Maintainer: Dawid Weglarz <dawid.weglarz95@gmail.com>
+
pkgname=nyrna
-pkgver=1.3
+pkgver=2.2.0
pkgrel=1
-pkgdesc='Simple program to pause games & applications'
+pkgdesc='Suspend games and applications at any time and resume whenever you wish'
arch=('x86_64')
url="https://github.com/Merrit/nyrna"
-license=('GPL3 or any later version')
-depends=('gtk3' 'libappindicator-gtk3' 'zenity')
-makedepends=('go' 'gcc' 'libxkbcommon-x11')
-source=("$pkgname-$pkgver.tar.gz::https://github.com/Merrit/nyrna/archive/v$pkgver.tar.gz")
-sha256sums=('7137706aaf09cc49acf8b5971e614871cd7d370748c415fd542c68cb1f2b1b26')
+license=('GPL3')
+depends=('wmctrl' 'xdotool')
+makedepends=('flutter')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/Merrit/nyrna/archive/refs/tags/v$pkgver.tar.gz")
+sha256sums=('88a288a56a60c5a9262da330fff44ba6f09e3a5801105f247a96f4b3345850eb')
prepare(){
cd "$pkgname-$pkgver"
+ flutter clean
+ flutter pub get
}
build() {
cd "$pkgname-$pkgver"
- export CGO_CPPFLAGS="${CPPFLAGS}"
- export CGO_CFLAGS="${CFLAGS}"
- export CGO_CXXFLAGS="${CXXFLAGS}"
- export CGO_LDFLAGS="${LDFLAGS}"
- export GOFLAGS="-buildmode=pie -trimpath -mod=readonly -modcacherw"
- go build
-}
-
-check() {
- cd "$pkgname-$pkgver"
+ flutter build linux
}
package() {
- cd "$pkgname-$pkgver"
- install -Dm755 $pkgname "$pkgdir"/usr/bin/$pkgname
- install -Dm644 "$srcdir/$pkgname-$pkgver/packaging/PKGBUILD/$pkgname.desktop" "$pkgdir/usr/share/applications/$pkgname.desktop"
- install -Dm644 "$srcdir/$pkgname-$pkgver/packaging/PKGBUILD/$pkgname.png" "$pkgdir/usr/share/pixmaps/$pkgname.png"
+ mkdir -p "${pkgdir}/opt/${pkgname}"
+ cp -r "${srcdir}/${pkgname}-${pkgver}/build/linux/x64/release/bundle/data" "${pkgdir}/opt/${pkgname}"
+ cp -r "${srcdir}/${pkgname}-${pkgver}/build/linux/x64/release/bundle/lib" "${pkgdir}/opt/${pkgname}"
+ cp "${srcdir}/${pkgname}-${pkgver}/build/linux/x64/release/bundle/${pkgname}" "${pkgdir}/opt/${pkgname}"
+
+ mkdir -p "${pkgdir}/usr/bin/"
+ ln -s "/opt/${pkgname}/${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
+
+ install -Dm644 "${srcdir}/${pkgname}-${pkgver}/packaging/linux/${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+ install -Dm644 "${srcdir}/${pkgname}-${pkgver}/assets/icons/${pkgname}.png" "${pkgdir}/usr/share/pixmaps/${pkgname}.png"
}
diff --git a/nyrna.desktop b/nyrna.desktop
deleted file mode 100644
index 5f20d05d962a..000000000000
--- a/nyrna.desktop
+++ /dev/null
@@ -1,10 +0,0 @@
-[Desktop Entry]
-Version=1.3
-Type=Application
-Name=Nyrna
-Comment=Simple program to pause games & applications
-Exec=nyrna
-Icon=nyrna
-Terminal=false
-StartupNotify=false
-Categories=Utility;
diff --git a/nyrna.png b/nyrna.png
deleted file mode 100644
index 1cacece602d2..000000000000
--- a/nyrna.png
+++ /dev/null
Binary files differ