summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKristen McWilliam2020-06-26 18:10:49 -0400
committerKristen McWilliam2020-06-26 18:10:49 -0400
commit7c9591ac3075bbc232515c8b4e39e02d60e934c2 (patch)
treeba0fc66b231a89179608692676db553ba10eb256
downloadaur-7c9591ac3075bbc232515c8b4e39e02d60e934c2.tar.gz
Initial version of PKGBUILD for AUR and Nyrna v1.0
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD41
3 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8da6bd12e2ff
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = nyrna
+ pkgdesc = Simple program to pause games & applications
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/Merrit/nyrna
+ arch = x86_64
+ license = GPL3 or any later version
+ makedepends = go
+ optdepends = libappindicator-gtk3: Tray icon support on GNOME
+ source = nyrna-1.0.tar.gz::https://github.com/Merrit/nyrna/archive/v1.0.tar.gz
+ sha256sums = e35f28ef2f76a25e8aaa7182c222e48063d208178b49a7e8d249ef947ab14a22
+
+pkgname = nyrna
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..04b373b039d3
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+# KDE's Dolphin
+.directory
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c23fa2188246
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Kristen McWilliam <merritt_public at outlook dot com>
+pkgname=nyrna
+pkgver=1.0
+pkgrel=1
+pkgdesc='Simple program to pause games & applications'
+arch=('x86_64')
+url="https://github.com/Merrit/nyrna"
+license=('GPL3 or any later version')
+optdepends=('libappindicator-gtk3: Tray icon support on GNOME')
+makedepends=('go')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/Merrit/nyrna/archive/v$pkgver.tar.gz")
+sha256sums=('e35f28ef2f76a25e8aaa7182c222e48063d208178b49a7e8d249ef947ab14a22')
+
+prepare(){
+ gendesk -n --pkgname "$pkgname" --pkgdesc "$pkgdesc"
+ cd "$pkgname-$pkgver"
+ mkdir -p build/
+}
+
+build() {
+ cd "$pkgname-$pkgver"
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export GOFLAGS="-buildmode=pie -trimpath -mod=readonly -modcacherw"
+ go build -o build ./cmd/...
+}
+
+check() {
+ cd "$pkgname-$pkgver"
+ go test ./...
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -Dm755 build/$pkgname "$pkgdir"/usr/bin/$pkgname
+ install -Dm644 "$pkgname.desktop" "$pkgdir/usr/share/applications/$pkgname.desktop"
+ install -Dm644 "../../nyrna/icons/$pkgname.png" "$pkgdir/usr/share/pixmaps/$pkgname.png"
+
+}