summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDct Mei2022-03-29 23:00:41 +0800
committerDct Mei2022-03-29 23:00:41 +0800
commit26c1bae327ecdca10589b962bfd28ff687c187be (patch)
treea9a1c38db22cfed075f27c9594da54d35f39bd23
parent7f8d3b5c97029d25afddb1e0fc8dfa89c08eb8b5 (diff)
downloadaur-26c1bae327ecdca10589b962bfd28ff687c187be.tar.gz
fix: use the latest stable version
1. v3 to v2.2.4 . see: atlas-engineer/nyxt#2144
-rw-r--r--.SRCINFO6
-rw-r--r--Makefile.2.pre.release.7.patch46
-rw-r--r--PKGBUILD21
-rw-r--r--renderer-gi-gtk.lisp.issue.1374.patch15
4 files changed, 9 insertions, 79 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6d01a86639b7..35f9f0bdcaaf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = nyxt
pkgdesc = A keyboard-oriented, infinitely extensible web browser designed for power users
- pkgver = 3
+ pkgver = 2.2.4
pkgrel = 1
url = https://github.com/atlas-engineer/nyxt
arch = x86_64
@@ -25,7 +25,7 @@ pkgbase = nyxt
conflicts = nyxt-browser
options = !strip
options = !makeflags
- source = git+https://github.com/atlas-engineer/nyxt.git#tag=3
- sha256sums = SKIP
+ source = git+https://github.com/atlas-engineer/nyxt.git#tag=2.2.4
+ b2sums = SKIP
pkgname = nyxt
diff --git a/Makefile.2.pre.release.7.patch b/Makefile.2.pre.release.7.patch
deleted file mode 100644
index 238422dfde61..000000000000
--- a/Makefile.2.pre.release.7.patch
+++ /dev/null
@@ -1,46 +0,0 @@
-diff --git a/Makefile b/Makefile
-index 1ede1854..c5021977 100644
---- a/Makefile
-+++ b/Makefile
-@@ -9,8 +9,13 @@ LISP ?= sbcl
- ## We use --non-interactive with SBCL so that errors don't interrupt the CI.
- LISP_FLAGS ?= --no-userinit --non-interactive
-
--NYXT_INTERNAL_QUICKLISP=true
--NYXT_RENDERER=gi-gtk
-+NYXT_INTERNAL_QUICKLISP = true
-+NYXT_RENDERER = gi-gtk
-+
-+PREFIX = /usr/local
-+prefix = $(PREFIX)
-+BINDIR = $(PREFIX)/bin
-+DATADIR = $(PREFIX)/share
-
- .PHONY: help
- help:
-@@ -60,7 +65,25 @@ ifeq ($(UNAME), Darwin)
- all: nyxt app-bundle
- endif
-
-+.PHONY: install-assets
-+install-assets:
-+ mkdir -p "$(DESTDIR)$(DATADIR)/applications/"
-+ sed "s/VERSION/$$(git describe --tags)/" assets/nyxt.desktop > "$(DESTDIR)$(DATADIR)/applications/nyxt.desktop"
-+ for i in 16 32 128 256 512; do \
-+ mkdir -p "$(DESTDIR)$(DATADIR)/icons/hicolor/$${i}x$${i}/apps/" ; \
-+ cp -f assets/nyxt_$${i}x$${i}.png "$(DESTDIR)$(DATADIR)/icons/hicolor/$${i}x$${i}/apps/nyxt.png" ; \
-+ done
-+
-+.PHONY: install-nyxt
-+install-nyxt: nyxt
-+ mkdir -p "$(DESTDIR)$(BINDIR)"
-+ cp -f $< "$(DESTDIR)$(BINDIR)/"
-+ chmod 755 "$(DESTDIR)$(BINDIR)/"$<
-+
- .PHONY: install
-+ifeq ($(UNAME), Linux)
-+install: install-nyxt install-assets
-+endif
- ifeq ($(UNAME), Darwin)
- install: install-app-bundle
- else
diff --git a/PKGBUILD b/PKGBUILD
index 733d1919f709..c345125e8aa6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,35 +5,26 @@
# Contributor: Felix Golatofski <contact@xdfr.de>
pkgname=nyxt
-pkgver=3
+pkgver=2.2.4
pkgrel=1
pkgdesc="A keyboard-oriented, infinitely extensible web browser designed for power users"
arch=('x86_64')
url="https://github.com/atlas-engineer/nyxt"
license=('custom:BSD')
-conflicts=('nyxt-browser')
-provides=('nyxt-browser' 'next-browser')
-source=("git+https://github.com/atlas-engineer/nyxt.git#tag=${pkgver}")
-#source=("git+https://github.com/atlas-engineer/nyxt.git#tag=${pkgver//./-}"
-# "Makefile.2.pre.release.7.patch"
-# "renderer-gi-gtk.lisp.issue.1374.patch")
-sha256sums=('SKIP')
+depends=('enchant' 'glib-networking' 'gobject-introspection-runtime' 'gsettings-desktop-schemas' 'libfixposix' 'webkit2gtk')
# If someday Next works with other Lisps, replace 'sbcl' with 'common-lisp'.
makedepends=('cl-asdf' 'git' 'gobject-introspection-runtime' 'sbcl')
-depends=('enchant' 'glib-networking' 'gobject-introspection-runtime' 'gsettings-desktop-schemas' 'libfixposix' 'webkit2gtk')
optdepends=('gstreamer: for HTML5 audio/video'
'gst-plugins-base: for HTML5 audio/video'
'gst-plugins-good: for HTML5 audio/video'
'gst-plugins-bad: for HTML5 audio/video'
'gst-plugins-ugly: for HTML5 audio/video')
+provides=('nyxt-browser' 'next-browser')
+conflicts=('nyxt-browser')
# Binary will not run otherwise.
options=('!strip' '!makeflags')
-
-#prepare() {
-# cd "${srcdir}"/"${pkgname}"/
-# patch -p1 -i ../Makefile.2.pre.release.7.patch
-# patch -p1 -i ../renderer-gi-gtk.lisp.issue.1374.patch
-#}
+source=("git+https://github.com/atlas-engineer/nyxt.git#tag=${pkgver}")
+b2sums=('SKIP')
build() {
cd "${srcdir}"/"${pkgname}"/
diff --git a/renderer-gi-gtk.lisp.issue.1374.patch b/renderer-gi-gtk.lisp.issue.1374.patch
deleted file mode 100644
index b6ebd96e2cc0..000000000000
--- a/renderer-gi-gtk.lisp.issue.1374.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-diff --git a/source/renderer-gi-gtk.lisp b/source/renderer-gi-gtk.lisp
-index 5684866a..f01097df 100644
---- a/source/renderer-gi-gtk.lisp
-+++ b/source/renderer-gi-gtk.lisp
-@@ -24,8 +24,8 @@
- (lambda ()
- (with-protect ("Error on GTK thread: ~a" :condition)
- (glib:g-set-prgname "nyxt")
-- (gdk:gdk-set-program-class "Nyxt")
-- (gir:invoke ((gir:ffi "Gtk") 'main))))
-+ ;;(gdk:gdk-set-program-class "Nyxt")
-+ (gir:invoke ((gir:ffi "Gtk" "3.0") 'main))))
- :name "main thread")))
- (finalize browser urls startup-timestamp)
- (unless *run-from-repl-p*