summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlilac2021-05-08 18:09:56 +0800
committerlilac2021-05-08 18:09:56 +0800
commit8a85231003c9f520177fdf162a8b244865624821 (patch)
tree1ed2b5ff785dbf0121e8f1e7b2cc1f906dd668ed
parentc0288833625b83a643f0cc15cf75e501a309bf1c (diff)
downloadaur-8a85231003c9f520177fdf162a8b244865624821.tar.gz
[lilac] updated to 2.pre.release.7-2
-rw-r--r--.SRCINFO13
-rw-r--r--Makefile.2.pre.release.7.patch46
-rw-r--r--PKGBUILD22
3 files changed, 71 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 96dce559ca50..e3f22ab18e17 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,19 @@
pkgbase = nyxt
pkgdesc = A keyboard-oriented, infinitely extensible web browser designed for power users
- pkgver = 2.pre.release.6
+ pkgver = 2.pre.release.7
pkgrel = 2
url = https://github.com/atlas-engineer/nyxt
arch = x86_64
license = custom:BSD
+ makedepends = cl-asdf
makedepends = git
+ makedepends = gobject-introspection-runtime
makedepends = sbcl
- makedepends = cl-asdf
- depends = webkit2gtk
+ depends = enchant
depends = glib-networking
depends = gsettings-desktop-schemas
depends = libfixposix
- depends = enchant
+ depends = webkit2gtk
optdepends = gstreamer: for HTML5 audio/video
optdepends = gst-plugins-base: for HTML5 audio/video
optdepends = gst-plugins-good: for HTML5 audio/video
@@ -23,8 +24,10 @@ pkgbase = nyxt
conflicts = nyxt-browser
options = !strip
options = !makeflags
- source = git+https://github.com/atlas-engineer/nyxt.git#tag=2-pre-release-6
+ source = git+https://github.com/atlas-engineer/nyxt.git#tag=2-pre-release-7
+ source = Makefile.2.pre.release.7.patch
sha256sums = SKIP
+ sha256sums = a6c833611d87c08e4c45299f5dda860b41cb3fea79fdde4bfb063cfeee5273e7
pkgname = nyxt
diff --git a/Makefile.2.pre.release.7.patch b/Makefile.2.pre.release.7.patch
new file mode 100644
index 000000000000..238422dfde61
--- /dev/null
+++ b/Makefile.2.pre.release.7.patch
@@ -0,0 +1,46 @@
+diff --git a/Makefile b/Makefile
+index 1ede1854..c5021977 100644
+--- a/Makefile
++++ b/Makefile
+@@ -9,8 +9,13 @@ LISP ?= sbcl
+ ## We use --non-interactive with SBCL so that errors don't interrupt the CI.
+ LISP_FLAGS ?= --no-userinit --non-interactive
+
+-NYXT_INTERNAL_QUICKLISP=true
+-NYXT_RENDERER=gi-gtk
++NYXT_INTERNAL_QUICKLISP = true
++NYXT_RENDERER = gi-gtk
++
++PREFIX = /usr/local
++prefix = $(PREFIX)
++BINDIR = $(PREFIX)/bin
++DATADIR = $(PREFIX)/share
+
+ .PHONY: help
+ help:
+@@ -60,7 +65,25 @@ ifeq ($(UNAME), Darwin)
+ all: nyxt app-bundle
+ endif
+
++.PHONY: install-assets
++install-assets:
++ mkdir -p "$(DESTDIR)$(DATADIR)/applications/"
++ sed "s/VERSION/$$(git describe --tags)/" assets/nyxt.desktop > "$(DESTDIR)$(DATADIR)/applications/nyxt.desktop"
++ for i in 16 32 128 256 512; do \
++ mkdir -p "$(DESTDIR)$(DATADIR)/icons/hicolor/$${i}x$${i}/apps/" ; \
++ cp -f assets/nyxt_$${i}x$${i}.png "$(DESTDIR)$(DATADIR)/icons/hicolor/$${i}x$${i}/apps/nyxt.png" ; \
++ done
++
++.PHONY: install-nyxt
++install-nyxt: nyxt
++ mkdir -p "$(DESTDIR)$(BINDIR)"
++ cp -f $< "$(DESTDIR)$(BINDIR)/"
++ chmod 755 "$(DESTDIR)$(BINDIR)/"$<
++
+ .PHONY: install
++ifeq ($(UNAME), Linux)
++install: install-nyxt install-assets
++endif
+ ifeq ($(UNAME), Darwin)
+ install: install-app-bundle
+ else
diff --git a/PKGBUILD b/PKGBUILD
index 4c4d31aa6c26..fdb19d2a734f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
# Contributor: Felix Golatofski <contact@xdfr.de>
pkgname=nyxt
-pkgver=2.pre.release.6
+pkgver=2.pre.release.7
pkgrel=2
pkgdesc="A keyboard-oriented, infinitely extensible web browser designed for power users"
arch=('x86_64')
@@ -13,11 +13,13 @@ url="https://github.com/atlas-engineer/nyxt"
license=('custom:BSD')
conflicts=('nyxt-browser')
provides=('nyxt-browser' 'next-browser')
-source=("git+https://github.com/atlas-engineer/nyxt.git#tag=${pkgver//./-}")
-sha256sums=('SKIP')
+source=("git+https://github.com/atlas-engineer/nyxt.git#tag=${pkgver//./-}"
+ "Makefile.2.pre.release.7.patch")
+sha256sums=('SKIP'
+ 'a6c833611d87c08e4c45299f5dda860b41cb3fea79fdde4bfb063cfeee5273e7')
# If someday Next works with other Lisps, replace 'sbcl' with 'common-lisp'.
-makedepends=('git' 'sbcl' 'cl-asdf')
-depends=('webkit2gtk' 'glib-networking' 'gsettings-desktop-schemas' 'libfixposix' 'enchant')
+makedepends=('cl-asdf' 'git' 'gobject-introspection-runtime' 'sbcl')
+depends=('enchant' 'glib-networking' 'gsettings-desktop-schemas' 'libfixposix' 'webkit2gtk')
optdepends=('gstreamer: for HTML5 audio/video'
'gst-plugins-base: for HTML5 audio/video'
'gst-plugins-good: for HTML5 audio/video'
@@ -26,6 +28,16 @@ optdepends=('gstreamer: for HTML5 audio/video'
# Binary will not run otherwise.
options=('!strip' '!makeflags')
+prepare() {
+ cd "${srcdir}"/"${pkgname}"/
+ patch -p1 -i ../Makefile.2.pre.release.7.patch
+}
+
+build() {
+ cd "${srcdir}"/"${pkgname}"/
+ make all
+}
+
package() {
cd "${srcdir}"/"${pkgname}"/
make install PREFIX=/usr DESTDIR="${pkgdir}"/