summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlilac2021-05-10 16:21:10 +0800
committerlilac2021-05-10 16:21:10 +0800
commitb1d07a02ccb79d3899eb13900eff98b0740112d0 (patch)
tree4eae80134ede409cf23b7f0abac183b957697dd2
parent8a85231003c9f520177fdf162a8b244865624821 (diff)
downloadaur-b1d07a02ccb79d3899eb13900eff98b0740112d0.tar.gz
[lilac] updated to 2.pre.release.7-3
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
-rw-r--r--renderer-gi-gtk.lisp.issue.1374.patch15
3 files changed, 24 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e3f22ab18e17..2fa2c3d829b6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = nyxt
pkgdesc = A keyboard-oriented, infinitely extensible web browser designed for power users
pkgver = 2.pre.release.7
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/atlas-engineer/nyxt
arch = x86_64
license = custom:BSD
@@ -26,8 +26,10 @@ pkgbase = nyxt
options = !makeflags
source = git+https://github.com/atlas-engineer/nyxt.git#tag=2-pre-release-7
source = Makefile.2.pre.release.7.patch
+ source = renderer-gi-gtk.lisp.issue.1374.patch
sha256sums = SKIP
sha256sums = a6c833611d87c08e4c45299f5dda860b41cb3fea79fdde4bfb063cfeee5273e7
+ sha256sums = 42ca7bf665b2cc4a632f7ec7d8e4f8f8dfb72739ecdce2fdeb607804c838f9d7
pkgname = nyxt
diff --git a/PKGBUILD b/PKGBUILD
index fdb19d2a734f..df00b8a8b1a6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
pkgname=nyxt
pkgver=2.pre.release.7
-pkgrel=2
+pkgrel=3
pkgdesc="A keyboard-oriented, infinitely extensible web browser designed for power users"
arch=('x86_64')
url="https://github.com/atlas-engineer/nyxt"
@@ -14,9 +14,11 @@ license=('custom:BSD')
conflicts=('nyxt-browser')
provides=('nyxt-browser' 'next-browser')
source=("git+https://github.com/atlas-engineer/nyxt.git#tag=${pkgver//./-}"
- "Makefile.2.pre.release.7.patch")
+ "Makefile.2.pre.release.7.patch"
+ "renderer-gi-gtk.lisp.issue.1374.patch")
sha256sums=('SKIP'
- 'a6c833611d87c08e4c45299f5dda860b41cb3fea79fdde4bfb063cfeee5273e7')
+ 'a6c833611d87c08e4c45299f5dda860b41cb3fea79fdde4bfb063cfeee5273e7'
+ '42ca7bf665b2cc4a632f7ec7d8e4f8f8dfb72739ecdce2fdeb607804c838f9d7')
# If someday Next works with other Lisps, replace 'sbcl' with 'common-lisp'.
makedepends=('cl-asdf' 'git' 'gobject-introspection-runtime' 'sbcl')
depends=('enchant' 'glib-networking' 'gsettings-desktop-schemas' 'libfixposix' 'webkit2gtk')
@@ -31,6 +33,7 @@ options=('!strip' '!makeflags')
prepare() {
cd "${srcdir}"/"${pkgname}"/
patch -p1 -i ../Makefile.2.pre.release.7.patch
+ patch -p1 -i ../renderer-gi-gtk.lisp.issue.1374.patch
}
build() {
diff --git a/renderer-gi-gtk.lisp.issue.1374.patch b/renderer-gi-gtk.lisp.issue.1374.patch
new file mode 100644
index 000000000000..b6ebd96e2cc0
--- /dev/null
+++ b/renderer-gi-gtk.lisp.issue.1374.patch
@@ -0,0 +1,15 @@
+diff --git a/source/renderer-gi-gtk.lisp b/source/renderer-gi-gtk.lisp
+index 5684866a..f01097df 100644
+--- a/source/renderer-gi-gtk.lisp
++++ b/source/renderer-gi-gtk.lisp
+@@ -24,8 +24,8 @@
+ (lambda ()
+ (with-protect ("Error on GTK thread: ~a" :condition)
+ (glib:g-set-prgname "nyxt")
+- (gdk:gdk-set-program-class "Nyxt")
+- (gir:invoke ((gir:ffi "Gtk") 'main))))
++ ;;(gdk:gdk-set-program-class "Nyxt")
++ (gir:invoke ((gir:ffi "Gtk" "3.0") 'main))))
+ :name "main thread")))
+ (finalize browser urls startup-timestamp)
+ (unless *run-from-repl-p*