summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2020-12-23 22:11:34 +0100
committerhaawda2020-12-23 22:11:34 +0100
commitb7b38a40039edc0a77d118b205764d61b5344a0b (patch)
tree16ecb1c110afe35946ae0806dfe4444df9bb8545
downloadaur-b7b38a40039edc0a77d118b205764d61b5344a0b.tar.gz
initial upload
-rw-r--r--.SRCINFO31
-rw-r--r--PKGBUILD32
2 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..00e6e731a773
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,31 @@
+pkgbase = nyxt
+ pkgdesc = Keyboard-oriented, Common Lisp extensible web-browser
+ pkgver = 2.pre.release.5
+ pkgrel = 1
+ url = https://nyxt.atlas.engineer
+ arch = i686
+ arch = x86_64
+ license = custom:BSD
+ makedepends = git
+ makedepends = sbcl
+ makedepends = cl-asdf
+ depends = webkit2gtk
+ depends = glib-networking
+ depends = gsettings-desktop-schemas
+ depends = libfixposix
+ depends = enchant
+ optdepends = gstreamer: for HTML5 audio/video
+ optdepends = gst-plugins-base: for HTML5 audio/video
+ optdepends = gst-plugins-good: for HTML5 audio/video
+ optdepends = gst-plugins-bad: for HTML5 audio/video
+ optdepends = gst-plugins-ugly: for HTML5 audio/video
+ provides = nyxt-browser
+ provides = next-browser
+ conflicts = nyxt-browser
+ options = !strip
+ options = !makeflags
+ source = git+https://github.com/atlas-engineer/nyxt.git#commit=a065942ce03be5b85addf3fa0b9b5617f5ee1e08
+ sha256sums = SKIP
+
+pkgname = nyxt
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4fc4bcb8813a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Contributor: Cillian Berragan <cjberragan@gmail.com>
+# Contributor: Felix Golatofski <contact@xdfr.de>
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+
+pkgname=nyxt
+pkgver=2.pre.release.5
+pkgrel=1
+pkgdesc="Keyboard-oriented, Common Lisp extensible web-browser"
+arch=('i686' 'x86_64')
+url="https://nyxt.atlas.engineer"
+license=('custom:BSD')
+conflicts=('nyxt-browser')
+provides=('nyxt-browser' 'next-browser')
+source=(git+https://github.com/atlas-engineer/nyxt.git#commit=a065942ce03be5b85addf3fa0b9b5617f5ee1e08)
+sha256sums=('SKIP')
+# If someday Next works with other Lisps, replace 'sbcl' with 'common-lisp'.
+makedepends=('git' 'sbcl' 'cl-asdf')
+depends=('webkit2gtk' 'glib-networking' 'gsettings-desktop-schemas' 'libfixposix' 'enchant')
+optdepends=('gstreamer: for HTML5 audio/video'
+ 'gst-plugins-base: for HTML5 audio/video'
+ 'gst-plugins-good: for HTML5 audio/video'
+ 'gst-plugins-bad: for HTML5 audio/video'
+ 'gst-plugins-ugly: for HTML5 audio/video')
+# Binary will not run otherwise.
+options=('!strip' '!makeflags')
+
+package() {
+ cd $pkgname
+ make install PREFIX=/usr DESTDIR=${pkgdir}
+ install -Dm644 licenses/ASSET-LICENSE "$pkgdir"/usr/share/licenses/$_pkgname/ASSET-LICENSE
+ install -Dm644 licenses/SOURCE-LICENSE "$pkgdir"/usr/share/licenses/$_pkgname/SOURCE-LICENSE
+}