summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMithicSpirit2021-08-08 12:18:57 -0400
committerMithicSpirit2021-08-08 12:18:57 -0400
commit1390e0173d6d75786a5a729d71ffab44d6dd7899 (patch)
tree35a64ad9cce2f2a83280ee2edd010eaa178589dd
parent4dabb1424c70296a2ee5e245180badd4e2a603bd (diff)
downloadaur-1390e0173d6d75786a5a729d71ffab44d6dd7899.tar.gz
Fix dependencies
Adds `gobject-introspection-runtime` to `depends` array. Also sorts dependencies alphabetically.
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD9
2 files changed, 11 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7ec267ff9e98..8bce5c8832ee 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = nyxt-browser-git
pkgdesc = Keyboard-oriented, Common Lisp extensible web-browser
- pkgver = 1.5.0.r1236.g10fdbf5b
+ pkgver = 2.1.1.r469.gaf599d8d
pkgrel = 1
url = https://nyxt.atlas.engineer
arch = i686
@@ -9,11 +9,12 @@ pkgbase = nyxt-browser-git
makedepends = git
makedepends = sbcl
makedepends = cl-asdf
- depends = webkit2gtk
+ depends = enchant
depends = glib-networking
+ depends = gobject-introspection-runtime
depends = gsettings-desktop-schemas
depends = libfixposix
- depends = enchant
+ depends = webkit2gtk
optdepends = gstreamer: for HTML5 audio/video
optdepends = gst-plugins-base: for HTML5 audio/video
optdepends = gst-plugins-good: for HTML5 audio/video
@@ -28,4 +29,3 @@ pkgbase = nyxt-browser-git
sha256sums = SKIP
pkgname = nyxt-browser-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 6ac86843628b..bf92ae90a32c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgname=nyxt-browser
pkgname=$_pkgname-git
-pkgver=1.5.0.r1236.g10fdbf5b
+pkgver=2.1.1.r469.gaf599d8d
pkgrel=1
pkgdesc="Keyboard-oriented, Common Lisp extensible web-browser"
arch=('i686' 'x86_64')
@@ -15,7 +15,12 @@ source=($_pkgname::git+https://github.com/atlas-engineer/nyxt.git)
sha256sums=('SKIP')
# If someday Next works with other Lisps, replace 'sbcl' with 'common-lisp'.
makedepends=('git' 'sbcl' 'cl-asdf')
-depends=('webkit2gtk' 'glib-networking' 'gsettings-desktop-schemas' 'libfixposix' 'enchant')
+depends=('enchant'
+ 'glib-networking'
+ 'gobject-introspection-runtime'
+ 'gsettings-desktop-schemas'
+ 'libfixposix'
+ 'webkit2gtk')
optdepends=('gstreamer: for HTML5 audio/video'
'gst-plugins-base: for HTML5 audio/video'
'gst-plugins-good: for HTML5 audio/video'