summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMithicSpirit2022-04-01 21:11:57 -0400
committerMithicSpirit2022-04-01 21:11:57 -0400
commit1dbec4d4b7c24797dcf60c085e91fdd6ebd1ffaf (patch)
treeda2d5c7d6feae34f669d6cbed092366e36fcf769
parente98db83d864d2ca43f61a06d97fa5384eec2af71 (diff)
downloadaur-1dbec4d4b7c24797dcf60c085e91fdd6ebd1ffaf.tar.gz
Fix webkit2gtk dependency, overall improvements
- Changes webkit2gtk to webkit2gtk-4.1 - Installs all licenses (ASSET-LICENSE, SOURCE-LICENSE, as well as any others that are added to the correct ./licenses/ directory in the nyxt source code) - Fixes license field to custom:BSD instead of BSD-3 - Changes pkgver variable to "latest" to emphasize that this always pulls from the latest git commit (pkgver() function will still set the correct version at build-time) Thank you to @e-v for most of these!
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
2 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8bce5c8832ee..849af7b5f92b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,11 @@
pkgbase = nyxt-browser-git
pkgdesc = Keyboard-oriented, Common Lisp extensible web-browser
- pkgver = 2.1.1.r469.gaf599d8d
+ pkgver = latest
pkgrel = 1
url = https://nyxt.atlas.engineer
arch = i686
arch = x86_64
- license = BSD-3
+ license = custom:BSD
makedepends = git
makedepends = sbcl
makedepends = cl-asdf
@@ -14,7 +14,7 @@ pkgbase = nyxt-browser-git
depends = gobject-introspection-runtime
depends = gsettings-desktop-schemas
depends = libfixposix
- depends = webkit2gtk
+ depends = webkit2gtk-4.1
optdepends = gstreamer: for HTML5 audio/video
optdepends = gst-plugins-base: for HTML5 audio/video
optdepends = gst-plugins-good: for HTML5 audio/video
diff --git a/PKGBUILD b/PKGBUILD
index 9442006454ce..4e4482b35435 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,12 +4,12 @@
_pkgname=nyxt-browser
pkgname=$_pkgname-git
-pkgver=2.1.1.r469.gaf599d8d
+pkgver=latest
pkgrel=1
pkgdesc="Keyboard-oriented, Common Lisp extensible web-browser"
arch=('i686' 'x86_64')
url="https://nyxt.atlas.engineer"
-license=('BSD-3')
+license=('custom:BSD')
conflicts=('nyxt-browser')
provides=('nyxt-browser' 'next-browser')
source=($_pkgname::git+https://github.com/atlas-engineer/nyxt.git)
@@ -21,7 +21,7 @@ depends=('enchant'
'gobject-introspection-runtime'
'gsettings-desktop-schemas'
'libfixposix'
- 'webkit2gtk')
+ 'webkit2gtk-4.1')
optdepends=('gstreamer: for HTML5 audio/video'
'gst-plugins-base: for HTML5 audio/video'
'gst-plugins-good: for HTML5 audio/video'
@@ -33,7 +33,6 @@ options=('!strip' '!makeflags')
pkgver() {
cd "$srcdir/$_pkgname"
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
-
}
build() {
@@ -44,5 +43,6 @@ build() {
package() {
cd "$srcdir/$_pkgname"
make install PREFIX=/usr DESTDIR=${pkgdir}
- install -Dm644 licenses/ASSET-LICENSE "$pkgdir"/usr/share/licenses/$_pkgname/licenses/ASSET-LICENSE
+ install -dm755 "$pkgdir"/usr/share/licenses/$pkgname/
+ install -m644 licenses/* "$pkgdir"/usr/share/licenses/$pkgname/
}