summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGoliathLabs2020-06-10 18:06:20 +0200
committerGoliathLabs2020-06-10 18:06:20 +0200
commit9b07f0263dce46599ee9294d9920adddb2f5c914 (patch)
tree570df3bf417c35824f7b7761c5359dca84754f05
downloadaur-9b07f0263dce46599ee9294d9920adddb2f5c914.tar.gz
Initial commit
-rw-r--r--.SRCINFO31
-rw-r--r--PKGBUILD42
2 files changed, 73 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7ec267ff9e98
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,31 @@
+pkgbase = nyxt-browser-git
+ pkgdesc = Keyboard-oriented, Common Lisp extensible web-browser
+ pkgver = 1.5.0.r1236.g10fdbf5b
+ pkgrel = 1
+ url = https://nyxt.atlas.engineer
+ arch = i686
+ arch = x86_64
+ license = BSD-3
+ makedepends = git
+ makedepends = sbcl
+ makedepends = cl-asdf
+ depends = webkit2gtk
+ depends = glib-networking
+ depends = gsettings-desktop-schemas
+ depends = libfixposix
+ depends = enchant
+ optdepends = gstreamer: for HTML5 audio/video
+ optdepends = gst-plugins-base: for HTML5 audio/video
+ optdepends = gst-plugins-good: for HTML5 audio/video
+ optdepends = gst-plugins-bad: for HTML5 audio/video
+ optdepends = gst-plugins-ugly: for HTML5 audio/video
+ provides = nyxt-browser
+ provides = next-browser
+ conflicts = nyxt-browser
+ options = !strip
+ options = !makeflags
+ source = nyxt-browser::git+https://github.com/atlas-engineer/nyxt.git
+ sha256sums = SKIP
+
+pkgname = nyxt-browser-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..51c96cbb4f9a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Cillian Berragan <cjberragan@gmail.com>
+# Contributor: Felix Golatofski <contact@xdfr.de>
+
+_pkgname=nyxt-browser
+pkgname=$_pkgname-git
+pkgver=1.5.0.r1236.g10fdbf5b
+pkgrel=1
+pkgdesc="Keyboard-oriented, Common Lisp extensible web-browser"
+arch=('i686' 'x86_64')
+url="https://nyxt.atlas.engineer"
+license=('BSD-3')
+conflicts=('nyxt-browser')
+provides=('nyxt-browser' 'next-browser')
+source=($_pkgname::git+https://github.com/atlas-engineer/nyxt.git)
+sha256sums=('SKIP')
+# If someday Next works with other Lisps, replace 'sbcl' with 'common-lisp'.
+makedepends=('git' 'sbcl' 'cl-asdf')
+depends=('webkit2gtk' 'glib-networking' 'gsettings-desktop-schemas' 'libfixposix' 'enchant')
+optdepends=('gstreamer: for HTML5 audio/video'
+ 'gst-plugins-base: for HTML5 audio/video'
+ 'gst-plugins-good: for HTML5 audio/video'
+ 'gst-plugins-bad: for HTML5 audio/video'
+ 'gst-plugins-ugly: for HTML5 audio/video')
+# Binary will not run otherwise.
+options=('!strip' '!makeflags')
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+
+}
+
+build() {
+ cd "$srcdir/$_pkgname"
+ make all
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ make install PREFIX=/usr DESTDIR=${pkgdir}
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$_pkgname/LICENSE
+}