summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJaroslav Lichtblau2014-11-28 20:17:14 +0100
committerJaroslav Lichtblau2014-11-28 20:17:14 +0100
commit806402fdbc90b48cad7d7501dc65e5b2734268e4 (patch)
tree10a2fecbc8037a5f5fe090cab35bbbed66d002d8
downloadaur-806402fdbc90b48cad7d7501dc65e5b2734268e4.tar.gz
Initial PKGBUILD status as of 28.11.2014
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD23
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bff0276f8b0a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = nzb
+ pkgdesc = A library and graphical Usenet client for nzb based NNTP downloading and streaming
+ pkgver = 0.2
+ pkgrel = 1
+ url = http://www.nzb.fi/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = openssl
+ depends = qt
+ source = http://downloads.sourceforge.net/sourceforge/nzb/nzb-0.2.tar.gz
+ sha256sums = df27606e8e016485a7e9cfb3aa7a2cea9f453d1f26901c02d53731ef0c816497
+
+pkgname = nzb
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2eab0741dc01
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Jaroslav Lichtblau <dragonlord@aur.archlinux.org>
+
+pkgname=nzb
+pkgver=0.2
+pkgrel=1
+pkgdesc="A library and graphical Usenet client for nzb based NNTP downloading and streaming"
+arch=('i686' 'x86_64')
+url="http://www.nzb.fi/"
+license=('GPL')
+depends=('openssl' 'qt')
+source=(http://downloads.sourceforge.net/sourceforge/$pkgname/$pkgname-$pkgver.tar.gz)
+sha256sums=('df27606e8e016485a7e9cfb3aa7a2cea9f453d1f26901c02d53731ef0c816497')
+
+build() {
+ cd ${srcdir}/$pkgname-$pkgver
+
+ qmake DESTDIR=${pkgdir}/usr/bin
+ make
+
+# ChangeLog
+ install -D -m644 ${srcdir}/$pkgname-$pkgver/ChangeLog \
+ ${pkgdir}/usr/share/doc/$pkgname/ChangeLog
+}