summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordryes2015-09-28 17:00:35 +0100
committerdryes2015-09-28 17:00:35 +0100
commitd406e2387de6e148f335156a14c4abded65edc73 (patch)
tree87636f14b255e356ae03d27dbc9285908f1670fc
downloadaur-d406e2387de6e148f335156a14c4abded65edc73.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD22
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..33630010e65f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v7
+# Mon Sep 28 16:00:26 UTC 2015
+pkgbase = nzbsubs-git
+ pkgdesc = takes an nzb input and removes all non-subtitle files.
+ pkgver = 16
+ pkgrel = 1
+ url = https://github.com/d2yes/nzbsubs
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = python2
+ depends = python2-pynzb
+ source = git://github.com/d2yes/nzbsubs.git
+ md5sums = SKIP
+
+pkgname = nzbsubs-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9aadd15fe96d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: dryes <joswiseman@cock.li>
+pkgname='nzbsubs-git'
+pkgver=16
+pkgrel=1
+pkgdesc='takes an nzb input and removes all non-subtitle files.'
+url='https://github.com/d2yes/nzbsubs'
+arch=('any')
+license=('MIT')
+depends=('python2' 'python2-pynzb')
+makedepends=('git')
+source=('git://github.com/d2yes/nzbsubs.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname%-git}"
+ echo $(git rev-list --count master)
+}
+
+package() {
+ mkdir -p "${pkgdir}/usr/bin"
+ install -D -m755 "${srcdir}/nzbsubs/nzbsubs.py" "${pkgdir}/usr/bin/nzbsubs"
+}