summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArthur LAURENT2024-03-29 15:07:39 +0100
committerArthur LAURENT2024-03-29 15:07:39 +0100
commit40e8d514bd872be0fdf4db32631c21489c58576b (patch)
tree3f0ccc15f5f73fd1f84eb7a22f10de5f90607ffc
downloadaur-40e8d514bd872be0fdf4db32631c21489c58576b.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD39
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e406c620ae37
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = nzsl
+ pkgdesc = A shader language inspired by Rust and C++ which compiles to GLSL or SPIRV (without any additional dependency)
+ pkgver = 20240227
+ pkgrel = 1
+ url = https://github.com/NazaraEngine/ShaderLang
+ arch = i686
+ arch = x86_64
+ arch = armv7h
+ arch = aarch64
+ license = MIT
+ makedepends = xmake
+ depends = fast_float
+ source = git+https://github.com/NazaraEngine/ShaderLang.git#commit=00426331127bca10b79498e3b1edf5a4d1d87986
+ sha256sums = SKIP
+
+pkgname = nzsl
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bebd677319d0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Arthur LAURENT <arthur.laurent@gmail.com>
+
+pkgname=nzsl
+pkgver=20240227
+pkgrel=1
+pkgdesc="A shader language inspired by Rust and C++ which compiles to GLSL or SPIRV (without any additional dependency)"
+arch=('i686' 'x86_64' 'armv7h' 'aarch64')
+url="https://github.com/NazaraEngine/ShaderLang"
+license=('MIT')
+options=()
+
+makedepends=('xmake')
+depends=('fast_float')
+
+source=("git+https://github.com/NazaraEngine/ShaderLang.git#commit=00426331127bca10b79498e3b1edf5a4d1d87986")
+
+sha256sums=('SKIP')
+
+prepare() {
+ cd "ShaderLang"
+ xmake f -m release --tests=y --examples=n --yes
+}
+
+build() {
+ cd "ShaderLang"
+ xmake b
+}
+
+check() {
+ cd "ShaderLang"
+ xmake run UnitTests
+}
+
+package() {
+ cd "ShaderLang"
+ xmake f --root -m release --tests=n --examples=n --yes
+ xmake install --root -o "${pkgdir}/usr"
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}