summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander F. Rødseth2022-11-17 00:27:26 +0100
committerAlexander F. Rødseth2022-11-17 00:27:26 +0100
commit9234ff30019287da62150ec9268716db2425ade8 (patch)
tree012903de3746a32ea62e8f66214fa4e57e3220c6
parentb7ca18df6bc3aea63bc2d60930bee0d6cd095709 (diff)
downloadaur-9234ff30019287da62150ec9268716db2425ade8.tar.gz
Update dependencies
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD12
2 files changed, 10 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7a2f18a68492..644ae1f41ff5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = o
pkgdesc = Text editor and minimalistic IDE
pkgver = 2.57.0
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/xyproto/o
arch = x86_64
license = BSD
@@ -17,7 +17,7 @@ pkgbase = o
optdepends = clojure: for compiling Clojure
optdepends = crystal: for compiling Crystal
optdepends = cxx: for compiling C and C++
- optdepends = elm: for compiling Elm
+ optdepends = elm-bin: for compiling Elm
optdepends = fpc: for compiling Object Pascal
optdepends = fstabfmt: for formatting /etc/fstab
optdepends = gdb: for debugging C
@@ -46,11 +46,11 @@ pkgbase = o
optdepends = scdoc: for writing man pages
optdepends = shfmt: for formattig Shell scripts
optdepends = tidy: for formatting HTML
- optdepends = v: for compiling and formatting V
+ optdepends = vlang: for compiling and formatting V
optdepends = vte3: for the ko GUI frontend
optdepends = yasm: for compiling Assembly
optdepends = zig: for compiling and formatting Zig
source = git+https://github.com/xyproto/o#commit=983e53231e91f3c24e0010c8ec9e17c9cff62442
+ b2sums = SKIP
pkgname = o
-
diff --git a/PKGBUILD b/PKGBUILD
index 1c307a01f5e8..9e2c1b8fc696 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=o
pkgver=2.57.0
-pkgrel=2
+pkgrel=3
pkgdesc='Text editor and minimalistic IDE'
arch=(x86_64)
url='https://github.com/xyproto/o'
@@ -18,7 +18,7 @@ optdepends=('asciidoctor: for writing man pages'
'clojure: for compiling Clojure'
'crystal: for compiling Crystal'
'cxx: for compiling C and C++'
- 'elm: for compiling Elm'
+ 'elm-bin: for compiling Elm'
'fpc: for compiling Object Pascal'
'fstabfmt: for formatting /etc/fstab'
'gdb: for debugging C'
@@ -47,7 +47,7 @@ optdepends=('asciidoctor: for writing man pages'
'scdoc: for writing man pages'
'shfmt: for formattig Shell scripts'
'tidy: for formatting HTML'
- 'v: for compiling and formatting V'
+ 'vlang: for compiling and formatting V'
'vte3: for the ko GUI frontend'
'yasm: for compiling Assembly'
'zig: for compiling and formatting Zig')
@@ -64,13 +64,13 @@ build() {
package() {
cd $pkgname
install -Dm755 o "$pkgdir/usr/bin/o"
+ install -Dm644 $pkgname.1 "$pkgdir/usr/share/man/man1/$pkgname.1"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ DESTDIR="$pkgdir" make gui-install
ln -sf /usr/bin/o "$pkgdir/usr/bin/edith"
ln -sf /usr/bin/o "$pkgdir/usr/bin/feedgame"
ln -sf /usr/bin/o "$pkgdir/usr/bin/lighted"
ln -sf /usr/bin/o "$pkgdir/usr/bin/redblack"
ln -sf /usr/bin/o "$pkgdir/usr/bin/sw"
- install -Dm644 $pkgname.1 "$pkgdir/usr/share/man/man1/$pkgname.1"
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
- DESTDIR="$pkgdir" make gui-install
ln -sf /usr/bin/ko "$pkgdir/usr/bin/lo"
}