summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander F. Rødseth2020-06-15 11:46:51 +0200
committerAlexander F. Rødseth2020-06-15 11:46:51 +0200
commita2bace348b485b082baf1c49ebd3b6ee1c1466bc (patch)
tree3d79308efdac735e8740e44b28df0ecaa9718b9b
parent2f45fce3667ac9c8b6f7e55171c39ae44583893d (diff)
downloadaur-a2bace348b485b082baf1c49ebd3b6ee1c1466bc.tar.gz
Add optional dependencies
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
2 files changed, 9 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f7165361dcd5..2b2005aa191d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,12 @@
pkgbase = o
pkgdesc = Small, fast and VT100-compatible text editor
pkgver = 2.30.2
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/xyproto/o
arch = x86_64
license = BSD
makedepends = git
- makedepends = go-pie
+ makedepends = go
optdepends = cxx: for compiling C++
optdepends = brittany: for formatting Haskell
optdepends = clang: for formatting C++ code with clang-format
@@ -20,6 +20,8 @@ pkgbase = o
optdepends = asciidoctor: for writing man pages
optdepends = pandoc: for exporting Markdown to PDF
optdepends = guessica: for updating PKGBUILD files
+ optdepends = kotlin: for compiling Kotlin code
+ optdepends = crystal: for compiling Crystal code
options = !strip
source = git+https://github.com/xyproto/o#commit=7327318e7c6837fe7aab4014a812223ba4a584a8
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 6ea4eb65918a..dbd34bd6edee 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,12 +2,12 @@
pkgname=o
pkgver=2.30.2
-pkgrel=1
+pkgrel=2
pkgdesc='Small, fast and VT100-compatible text editor'
arch=(x86_64)
url='https://github.com/xyproto/o'
license=(BSD)
-makedepends=(git go-pie)
+makedepends=(git go)
source=("git+$url#commit=7327318e7c6837fe7aab4014a812223ba4a584a8") # tag: 2.30.2
sha256sums=('SKIP')
options=(!strip)
@@ -23,7 +23,9 @@ optdepends=('cxx: for compiling C++'
'scdoc: for writing man pages'
'asciidoctor: for writing man pages'
'pandoc: for exporting Markdown to PDF'
- 'guessica: for updating PKGBUILD files')
+ 'guessica: for updating PKGBUILD files'
+ 'kotlin: for compiling Kotlin code'
+ 'crystal: for compiling Crystal code')
build() {
cd $pkgname