summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander F. Rødseth2021-08-04 19:03:37 +0200
committerAlexander F. Rødseth2021-08-04 19:03:37 +0200
commitc1e962b4768bbbd924e4648d06d6d167847dd401 (patch)
tree2ba71298f533d91d8a6c96e565ff68b885e9e698
parent2b48196297a77333ac2d6491f0439038d9d1b9e5 (diff)
downloadaur-c1e962b4768bbbd924e4648d06d6d167847dd401.tar.gz
New release
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD7
2 files changed, 8 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b08e7bbc939d..a37fbf4f5a8f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,13 @@
pkgbase = o
pkgdesc = Text editor
- pkgver = 2.40.1
+ pkgver = 2.41.0
pkgrel = 1
url = https://github.com/xyproto/o
arch = x86_64
license = BSD
makedepends = git
makedepends = go
+ depends = vte3
optdepends = asciidoctor: for writing man pages
optdepends = astyle: for formatting C#
optdepends = autopep8: for formatting Python
@@ -33,7 +34,7 @@ pkgbase = o
optdepends = tidy: for formatting HTML
optdepends = v: for compiling and formatting V
optdepends = zig: for compiling and formatting Zig
- source = git+https://github.com/xyproto/o#commit=d04156356c3c5ea00f47520257b04beacaf1cd40
+ source = git+https://github.com/xyproto/o#commit=da31088c13a2314c5720fae0f3f5e89ff227f50a
b2sums = SKIP
pkgname = o
diff --git a/PKGBUILD b/PKGBUILD
index ddd352050d31..f84116bb4005 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,15 @@
# Maintainer: Alexander F. Rødseth <xyproto@archlinux.org>
pkgname=o
-pkgver=2.40.1
+pkgver=2.41.0
pkgrel=1
pkgdesc='Text editor'
arch=(x86_64)
url='https://github.com/xyproto/o'
license=(BSD)
+depends=(vte3)
makedepends=(git go)
-source=("git+$url#commit=d04156356c3c5ea00f47520257b04beacaf1cd40") # tag: 2.40.1
+source=("git+$url#commit=da31088c13a2314c5720fae0f3f5e89ff227f50a") # tag: 2.41.0
optdepends=('asciidoctor: for writing man pages'
'astyle: for formatting C#'
'autopep8: for formatting Python'
@@ -40,6 +41,7 @@ b2sums=(SKIP)
build() {
cd $pkgname
go build -v -mod=vendor -trimpath -buildmode=pie -ldflags="-s -w -extldflags \"${LDFLAGS}\""
+ make gui
}
package() {
@@ -49,4 +51,5 @@ package() {
ln -sf /usr/bin/o "$pkgdir/usr/bin/ro"
install -Dm644 $pkgname.1 "$pkgdir/usr/share/man/man1/$pkgname.1"
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ DESTDIR="$pkgdir" make gui-install
}