summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander F. Rødseth2022-11-17 00:31:21 +0100
committerAlexander F. Rødseth2022-11-17 00:31:21 +0100
commit2c95958e5988f8100bfaa303ba7e2ec542cbac77 (patch)
tree77f2d05bdd020138f72ff7d90f047975132e0f72
parent46cabfa78f0cb065d0d3d8c211e99ae7bab3d2ba (diff)
downloadaur-2c95958e5988f8100bfaa303ba7e2ec542cbac77.tar.gz
Update dependencies
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD10
2 files changed, 10 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2ef994c49e70..313ede597727 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = o-bin
pkgdesc = Text editor, IDE and gdb frontend (CLI only)
pkgver = 2.57.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/xyproto/o
arch = aarch64
arch = armv6
@@ -18,7 +18,7 @@ pkgbase = o-bin
optdepends = clojure: for compiling Clojure
optdepends = crystal: for compiling Crystal
optdepends = cxx: for compiling C and C++
- optdepends = elm: for compiling Elm
+ optdepends = elm-bin: for compiling Elm
optdepends = fpc: for compiling Object Pascal
optdepends = fstabfmt: for formatting /etc/fstab
optdepends = gdb: for debugging C
@@ -47,12 +47,12 @@ pkgbase = o-bin
optdepends = scdoc: for writing man pages
optdepends = shfmt: for formattig Shell scripts
optdepends = tidy: for formatting HTML
- optdepends = v: for compiling and formatting V
+ optdepends = vlang: for compiling and formatting V
optdepends = yasm: for compiling Assembly
optdepends = zig: for compiling and formatting Zig
conflicts = o
- source = https://github.com/xyproto/o/releases/download/v2.57.0/o-2.57.0-linux__static.tar.xz
+ source = https://github.com/xyproto/o/releases/download/v2.57.0/o-2.57.0-linux_x86_64_static.tar.xz
sha256sums = 78fcd537465c43293770b87265a2c558279839151440e9c91deb570833e3e2a1
+ b2sums = 54e255c3912fc89acdc8add69ef9f6685e81a1edb1468d0f37f54482ee89db076aa16dabe766ce012aa39ba2edaf926f523f56ab6ab095b1bf4ee2aae430e791
pkgname = o-bin
-
diff --git a/PKGBUILD b/PKGBUILD
index 3b33b773349b..6d08841cd6cf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=o-bin
pkgver=2.57.0
-pkgrel=1
+pkgrel=2
pkgdesc='Text editor, IDE and gdb frontend (CLI only)'
arch=(aarch64 armv6 armv7 riscv64 x86_64)
url='https://github.com/xyproto/o'
@@ -18,7 +18,7 @@ optdepends=('asciidoctor: for writing man pages'
'clojure: for compiling Clojure'
'crystal: for compiling Crystal'
'cxx: for compiling C and C++'
- 'elm: for compiling Elm'
+ 'elm-bin: for compiling Elm'
'fpc: for compiling Object Pascal'
'fstabfmt: for formatting /etc/fstab'
'gdb: for debugging C'
@@ -47,7 +47,7 @@ optdepends=('asciidoctor: for writing man pages'
'scdoc: for writing man pages'
'shfmt: for formattig Shell scripts'
'tidy: for formatting HTML'
- 'v: for compiling and formatting V'
+ 'vlang: for compiling and formatting V'
'yasm: for compiling Assembly'
'zig: for compiling and formatting Zig')
sha256sums=('78fcd537465c43293770b87265a2c558279839151440e9c91deb570833e3e2a1')
@@ -56,11 +56,11 @@ b2sums=('54e255c3912fc89acdc8add69ef9f6685e81a1edb1468d0f37f54482ee89db076aa16da
package() {
cd o-$pkgver-linux_${CARCH}_static
install -Dm755 o "$pkgdir/usr/bin/o"
+ install -Dm644 o.1.gz "$pkgdir/usr/share/man/man1/o.1.gz"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
ln -sf /usr/bin/o "$pkgdir/usr/bin/edith"
ln -sf /usr/bin/o "$pkgdir/usr/bin/feedgame"
ln -sf /usr/bin/o "$pkgdir/usr/bin/vs"
ln -sf /usr/bin/o "$pkgdir/usr/bin/redblack"
ln -sf /usr/bin/o "$pkgdir/usr/bin/sw"
- install -Dm644 o.1.gz "$pkgdir/usr/share/man/man1/o.1.gz"
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}