summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander F. Rødseth2022-04-05 15:53:13 +0200
committerAlexander F. Rødseth2022-04-05 15:53:13 +0200
commit59b43049413b1de85efa34ef250dd91a35a062ce (patch)
treefd91d87ed4489f6096e069573d0471e9d9c49fd8
downloadaur-59b43049413b1de85efa34ef250dd91a35a062ce.tar.gz
Initial commit
-rw-r--r--.SRCINFO50
-rw-r--r--PKGBUILD63
2 files changed, 113 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cb49e2dfbf70
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,50 @@
+pkgbase = o-bin
+ pkgdesc = Text editor
+ pkgver = 2.49.0
+ pkgrel = 1
+ url = https://github.com/xyproto/o
+ arch = x86_64
+ license = BSD
+ optdepends = asciidoctor: for writing man pages
+ optdepends = agda: for compiling Agda
+ optdepends = astyle: for formatting C#
+ optdepends = autopep8: for formatting Python
+ optdepends = brittany: for formatting Haskell
+ optdepends = clang: for formatting C++ code with clang-format
+ optdepends = clojure: for compiling Clojure
+ optdepends = crystal: for compiling Crystal
+ optdepends = cxx: for compiling C and C++
+ optdepends = fpc: for compiling Object Pascal
+ optdepends = fstabfmt: for formatting /etc/fstab
+ optdepends = gdc: for compiling D
+ optdepends = ghc: for compiling Haskell
+ optdepends = google-java-format: for formatting Java
+ optdepends = guessica: for updating PKGBUILD files
+ optdepends = jad: for decompiling .class files on the fly
+ optdepends = java-environment: for compiling Java
+ optdepends = kotlin: for compiling Kotlin
+ optdepends = ktlint: for formatting Kotlin
+ optdepends = lua: for compiling Lua
+ optdepends = lua-format: for formatting Lua
+ optdepends = mlton: for compiling Standard ML
+ optdepends = mono: for compiling C#
+ optdepends = nasm: for compiling Assembly
+ optdepends = ocaml: for compiling and formatting OCaml
+ optdepends = odin: for compiling Odin
+ optdepends = perl-tidy: for formatting Perl
+ optdepends = pandoc-bin: for exporting Markdown to PDF
+ optdepends = prettier: for formatting JavaScript, TypeScript and CSS
+ optdepends = rustup: for compiling and formatting Rust
+ optdepends = scala: for compiling Scala
+ optdepends = scdoc: for writing man pages
+ optdepends = shfmt: for formattig Shell scripts
+ optdepends = tidy: for formatting HTML
+ optdepends = v: for compiling and formatting V
+ optdepends = yasm: for compiling Assembly
+ optdepends = zig: for compiling and formatting Zig
+ conflicts = o
+ source = https://github.com/xyproto/o/releases/download/v2.49.0/o-2.49.0-linux.tar.xz
+ sha256sums = c7e3a5e18e6584c0ee0e5e61ca56dbd595414c5758cfb171b1870785c4f1073c
+ b2sums = f416932afe2f8edfd2f108e2b80ea90518e9825ca7529504b08f7ae610bf687d47a2ea2f9e4af833df54a206719c43745285b14d6bb12625a099330ee65ac4b3
+
+pkgname = o-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a2fc2c1d44e0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,63 @@
+# Maintainer: Alexander F. Rødseth <xyproto@archlinux.org>
+
+pkgname=o-bin
+pkgver=2.49.0
+pkgrel=1
+pkgdesc='Text editor'
+arch=(x86_64)
+url='https://github.com/xyproto/o'
+license=(BSD)
+#depends=(vte3)
+conflicts=(o)
+source=("https://github.com/xyproto/o/releases/download/v$pkgver/o-$pkgver-linux.tar.xz")
+optdepends=('asciidoctor: for writing man pages'
+ 'agda: for compiling Agda'
+ 'astyle: for formatting C#'
+ 'autopep8: for formatting Python'
+ 'brittany: for formatting Haskell'
+ 'clang: for formatting C++ code with clang-format'
+ 'clojure: for compiling Clojure'
+ 'crystal: for compiling Crystal'
+ 'cxx: for compiling C and C++'
+ 'fpc: for compiling Object Pascal'
+ 'fstabfmt: for formatting /etc/fstab'
+ 'gdc: for compiling D'
+ 'ghc: for compiling Haskell'
+ 'google-java-format: for formatting Java'
+ 'guessica: for updating PKGBUILD files'
+ 'jad: for decompiling .class files on the fly'
+ 'java-environment: for compiling Java'
+ 'kotlin: for compiling Kotlin'
+ 'ktlint: for formatting Kotlin'
+ 'lua: for compiling Lua'
+ 'lua-format: for formatting Lua'
+ 'mlton: for compiling Standard ML'
+ 'mono: for compiling C#'
+ 'nasm: for compiling Assembly'
+ 'ocaml: for compiling and formatting OCaml'
+ 'odin: for compiling Odin'
+ 'perl-tidy: for formatting Perl'
+ 'pandoc-bin: for exporting Markdown to PDF'
+ 'prettier: for formatting JavaScript, TypeScript and CSS'
+ 'rustup: for compiling and formatting Rust'
+ 'scala: for compiling Scala'
+ 'scdoc: for writing man pages'
+ 'shfmt: for formattig Shell scripts'
+ 'tidy: for formatting HTML'
+ 'v: for compiling and formatting V'
+ 'yasm: for compiling Assembly'
+ 'zig: for compiling and formatting Zig')
+sha256sums=('c7e3a5e18e6584c0ee0e5e61ca56dbd595414c5758cfb171b1870785c4f1073c')
+b2sums=('f416932afe2f8edfd2f108e2b80ea90518e9825ca7529504b08f7ae610bf687d47a2ea2f9e4af833df54a206719c43745285b14d6bb12625a099330ee65ac4b3')
+
+package() {
+ cd o-$pkgver-linux
+ install -Dm755 o "$pkgdir/usr/bin/o"
+ ln -sf /usr/bin/o "$pkgdir/usr/bin/redblack"
+ ln -sf /usr/bin/o "$pkgdir/usr/bin/lighted"
+ ln -sf /usr/bin/o "$pkgdir/usr/bin/feedgame"
+ install -Dm644 o.1.gz "$pkgdir/usr/share/man/man1/o.1.gz"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ #install -Dm755 ko "$pkgdir/usr/bin/ko"
+ #ln -sf /usr/bin/ko "$pkgdir/usr/bin/lo"
+}