summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander F. Rødseth2023-01-26 13:32:52 +0100
committerAlexander F. Rødseth2023-01-26 13:32:52 +0100
commit735bf3b413361589007984f3691886ef0e6b3804 (patch)
tree761b8412ff6603d07cc6fe31151e8d1904bb9e02
parent92786d4fb1de0ab65c41bbbe39bc97f9b05f602c (diff)
downloadaur-735bf3b413361589007984f3691886ef0e6b3804.tar.gz
New release
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD16
2 files changed, 14 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 63b617999b6b..ad6a13388a87 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = o-bin
pkgdesc = Text editor, IDE and gdb frontend (CLI only)
- pkgver = 2.58.0
+ pkgver = 2.59.0
pkgrel = 1
url = https://github.com/xyproto/o
arch = aarch64
@@ -51,8 +51,8 @@ pkgbase = o-bin
optdepends = yasm: for compiling Assembly
optdepends = zig: for compiling and formatting Zig
conflicts = o
- source = https://github.com/xyproto/o/releases/download/v2.58.0/o-2.58.0-linux_x86_64_static.tar.xz
- sha256sums = 0e4d87d0f1b3ee281fd56d6424c3592429102fbfb3d16481c4b102c625a994b7
- b2sums = 913ccaef53bf943889d7920b5f0b730675fc5f9fab71f07d3b732b86a6cfcce5aee70e879728ef347e99dcff26ae394188e9103cb18cc34abf27b123d6d78c85
+ source = https://github.com/xyproto/o/releases/download/v2.59.0/o-2.59.0-linux_x86_64_static.tar.xz
+ sha256sums = 31d65f283c4f817b4314990f0d6cf62053e827d1711596148c71dc0489dc652c
+ b2sums = 04a0059e3206d4fe12324d8b2cc87b58d16923f0fdd845966dfd4e3396899aab045bfd4d8961739cd1aa84d8cb35cc4c674001e2c9a06f05edc1ad175e5546ca
pkgname = o-bin
diff --git a/PKGBUILD b/PKGBUILD
index bbe1a1f1479e..aaf7b84d57a8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Alexander F. Rødseth <xyproto@archlinux.org>
pkgname=o-bin
-pkgver=2.58.0
+pkgver=2.59.0
pkgrel=1
pkgdesc='Text editor, IDE and gdb frontend (CLI only)'
arch=(aarch64 armv6 armv7 riscv64 x86_64)
@@ -50,17 +50,21 @@ optdepends=('asciidoctor: for writing man pages'
'vlang: for compiling and formatting V'
'yasm: for compiling Assembly'
'zig: for compiling and formatting Zig')
-sha256sums=('0e4d87d0f1b3ee281fd56d6424c3592429102fbfb3d16481c4b102c625a994b7')
-b2sums=('913ccaef53bf943889d7920b5f0b730675fc5f9fab71f07d3b732b86a6cfcce5aee70e879728ef347e99dcff26ae394188e9103cb18cc34abf27b123d6d78c85')
+sha256sums=('31d65f283c4f817b4314990f0d6cf62053e827d1711596148c71dc0489dc652c')
+b2sums=('04a0059e3206d4fe12324d8b2cc87b58d16923f0fdd845966dfd4e3396899aab045bfd4d8961739cd1aa84d8cb35cc4c674001e2c9a06f05edc1ad175e5546ca')
package() {
cd o-$pkgver-linux_${CARCH}_static
+
install -Dm755 o "$pkgdir/usr/bin/o"
install -Dm644 o.1.gz "$pkgdir/usr/share/man/man1/o.1.gz"
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
- ln -sf /usr/bin/o "$pkgdir/usr/bin/edith"
- ln -sf /usr/bin/o "$pkgdir/usr/bin/feedgame"
- ln -sf /usr/bin/o "$pkgdir/usr/bin/vs"
+
+ # Recommended symlinks for o
+ ln -sf /usr/bin/o "$pkgdir/usr/bin/li"
ln -sf /usr/bin/o "$pkgdir/usr/bin/redblack"
ln -sf /usr/bin/o "$pkgdir/usr/bin/sw"
+ ln -sf /usr/bin/o "$pkgdir/usr/bin/edi"
+ ln -sf /usr/bin/o "$pkgdir/usr/bin/vs"
+ ln -sf /usr/bin/o "$pkgdir/usr/bin/feedgame"
}