summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander F. Rødseth2022-06-12 22:30:32 +0200
committerAlexander F. Rødseth2022-06-12 22:30:32 +0200
commit782ec3f04cfc60b55a2657c8aee41ace247a41fd (patch)
tree442921b15c4bca39631d800b2fd1f11ed7e6bda0
parent94f50a66e1d1f06e6ead1c94dbcba43c1b707752 (diff)
downloadaur-782ec3f04cfc60b55a2657c8aee41ace247a41fd.tar.gz
New release
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD9
2 files changed, 11 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 13125b79ecbb..664576a13a63 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,12 @@
pkgbase = o-bin
pkgdesc = Text editor
- pkgver = 2.51.0
+ pkgver = 2.52.0
pkgrel = 1
url = https://github.com/xyproto/o
arch = aarch64
arch = armv6
arch = armv7
+ arch = riscv64
arch = x86_64
license = BSD
optdepends = asciidoctor: for writing man pages
@@ -24,6 +25,7 @@ pkgbase = o-bin
optdepends = ghc: for compiling Haskell
optdepends = google-java-format: for formatting Java
optdepends = guessica: for updating PKGBUILD files
+ optdepends = hare: for compiling Hare
optdepends = jad: for decompiling .class files on the fly
optdepends = java-environment: for compiling Java
optdepends = kotlin: for compiling Kotlin
@@ -47,8 +49,8 @@ pkgbase = o-bin
optdepends = yasm: for compiling Assembly
optdepends = zig: for compiling and formatting Zig
conflicts = o
- source = https://github.com/xyproto/o/releases/download/v2.51.0/o-2.51.0-linux_x86_64_static.tar.xz
- sha256sums = 45de6fb5068620136b313c105894c8e14a8b0e25a68f0c2f9577d8a6338ea2fa
- b2sums = 98c6cc70eb43111ba1496c8d78f91e17228c53f41798febda8ecddbd4811564bb1e26e481ab3765154bb058a2606fbf9efd7e317fbbbbc85db682dfa315d8b84
+ source = https://github.com/xyproto/o/releases/download/v2.52.0/o-2.52.0-linux_x86_64_static.tar.xz
+ sha256sums = 0f58313339d230c95658f7ef311f83cc54ceb878c085bcf32ba68476e904b327
+ b2sums = a6a14bec7e9259d23ee7c33bf8294b4285d79d22242653dc0ee3a6634340be0da7c184fe1793fb080479fd053582d015212fcf1607473a052e81972f283689fe
pkgname = o-bin
diff --git a/PKGBUILD b/PKGBUILD
index 108d1460e212..bfc346d0d036 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,10 @@
# Maintainer: Alexander F. Rødseth <xyproto@archlinux.org>
pkgname=o-bin
-pkgver=2.51.0
+pkgver=2.52.0
pkgrel=1
pkgdesc='Text editor'
-arch=(aarch64 armv6 armv7 x86_64)
+arch=(aarch64 armv6 armv7 riscv64 x86_64)
url='https://github.com/xyproto/o'
license=(BSD)
conflicts=(o)
@@ -25,6 +25,7 @@ optdepends=('asciidoctor: for writing man pages'
'ghc: for compiling Haskell'
'google-java-format: for formatting Java'
'guessica: for updating PKGBUILD files'
+ 'hare: for compiling Hare'
'jad: for decompiling .class files on the fly'
'java-environment: for compiling Java'
'kotlin: for compiling Kotlin'
@@ -47,8 +48,8 @@ optdepends=('asciidoctor: for writing man pages'
'v: for compiling and formatting V'
'yasm: for compiling Assembly'
'zig: for compiling and formatting Zig')
-sha256sums=('45de6fb5068620136b313c105894c8e14a8b0e25a68f0c2f9577d8a6338ea2fa')
-b2sums=('98c6cc70eb43111ba1496c8d78f91e17228c53f41798febda8ecddbd4811564bb1e26e481ab3765154bb058a2606fbf9efd7e317fbbbbc85db682dfa315d8b84')
+sha256sums=('0f58313339d230c95658f7ef311f83cc54ceb878c085bcf32ba68476e904b327')
+b2sums=('a6a14bec7e9259d23ee7c33bf8294b4285d79d22242653dc0ee3a6634340be0da7c184fe1793fb080479fd053582d015212fcf1607473a052e81972f283689fe')
package() {
cd o-$pkgver-linux_${CARCH}_static