summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander F. Rødseth2022-04-08 18:45:09 +0200
committerAlexander F. Rødseth2022-04-08 18:45:09 +0200
commite989552edeab0f0b53ce4931b1952441450bb14a (patch)
treeac91ff675a8bd694496d36ec8996544c956e6da9
parentb6512d58d11edd28abdf3c633fe214b714b98347 (diff)
downloadaur-e989552edeab0f0b53ce4931b1952441450bb14a.tar.gz
New minor release
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD15
2 files changed, 17 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 42b4b67215af..80916104d853 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,11 @@
pkgbase = o-bin
- pkgdesc = Text editor (terminal only)
- pkgver = 2.49.1
+ pkgdesc = Text editor
+ pkgver = 2.50.0
pkgrel = 1
url = https://github.com/xyproto/o
+ arch = aarch64
+ arch = armv6
+ arch = armv7
arch = x86_64
license = BSD
optdepends = asciidoctor: for writing man pages
@@ -16,6 +19,7 @@ pkgbase = o-bin
optdepends = cxx: for compiling C and C++
optdepends = fpc: for compiling Object Pascal
optdepends = fstabfmt: for formatting /etc/fstab
+ optdepends = gdb: for debugging C
optdepends = gdc: for compiling D
optdepends = ghc: for compiling Haskell
optdepends = google-java-format: for formatting Java
@@ -43,8 +47,8 @@ pkgbase = o-bin
optdepends = yasm: for compiling Assembly
optdepends = zig: for compiling and formatting Zig
conflicts = o
- source = https://github.com/xyproto/o/releases/download/v2.49.1/o-2.49.1-linux_amd64.tar.xz
- sha256sums = bc92342c0a9eb8c69af7eb05f31d0a6df8a1f729ec35e1a98d27b52f8b7e0a6e
- b2sums = faf76e2dd7693d116bec9dbd01a58249faa46b0470630e2444c72f414736baa2da19148c4f779193e392880aff885842bb473b55bcb28c3196db6a012746c12b
+ source = https://github.com/xyproto/o/releases/download/v2.50.0/o-2.50.0-linux_x86_64_static.tar.xz
+ sha256sums = 49f71b018edc4a0217f79b6e6d88d35574493073c80b1d82e54bb94bd461284b
+ b2sums = 48ad9e51ef237e30aba3b9d799fe233cd34f6d1aacf36b29c8a2da5fb2197b2aa63fb129f154dcf5ce29c2fba485e3dff193a6be93212ece4e2d377c8efced34
pkgname = o-bin
diff --git a/PKGBUILD b/PKGBUILD
index ea30621af54b..a4729bbbbe70 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: Alexander F. Rødseth <xyproto@archlinux.org>
pkgname=o-bin
-pkgver=2.49.1
+pkgver=2.50.0
pkgrel=1
-pkgdesc='Text editor (terminal only)'
-arch=(x86_64)
+pkgdesc='Text editor'
+arch=(aarch64 armv6 armv7 x86_64)
url='https://github.com/xyproto/o'
license=(BSD)
conflicts=(o)
-source=("https://github.com/xyproto/o/releases/download/v$pkgver/o-$pkgver-linux_amd64.tar.xz")
+source=("https://github.com/xyproto/o/releases/download/v$pkgver/o-$pkgver-linux_${CARCH}_static.tar.xz")
optdepends=('asciidoctor: for writing man pages'
'agda: for compiling Agda'
'astyle: for formatting C#'
@@ -20,6 +20,7 @@ optdepends=('asciidoctor: for writing man pages'
'cxx: for compiling C and C++'
'fpc: for compiling Object Pascal'
'fstabfmt: for formatting /etc/fstab'
+ 'gdb: for debugging C'
'gdc: for compiling D'
'ghc: for compiling Haskell'
'google-java-format: for formatting Java'
@@ -46,11 +47,11 @@ optdepends=('asciidoctor: for writing man pages'
'v: for compiling and formatting V'
'yasm: for compiling Assembly'
'zig: for compiling and formatting Zig')
-sha256sums=('bc92342c0a9eb8c69af7eb05f31d0a6df8a1f729ec35e1a98d27b52f8b7e0a6e')
-b2sums=('faf76e2dd7693d116bec9dbd01a58249faa46b0470630e2444c72f414736baa2da19148c4f779193e392880aff885842bb473b55bcb28c3196db6a012746c12b')
+sha256sums=('49f71b018edc4a0217f79b6e6d88d35574493073c80b1d82e54bb94bd461284b')
+b2sums=('48ad9e51ef237e30aba3b9d799fe233cd34f6d1aacf36b29c8a2da5fb2197b2aa63fb129f154dcf5ce29c2fba485e3dff193a6be93212ece4e2d377c8efced34')
package() {
- cd o-$pkgver-linux_amd64
+ cd o-$pkgver-linux_${CARCH}_static
install -Dm755 o "$pkgdir/usr/bin/o"
ln -sf /usr/bin/o "$pkgdir/usr/bin/redblack"
ln -sf /usr/bin/o "$pkgdir/usr/bin/lighted"