summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDuong Do Minh Chau2020-04-16 14:01:12 +0700
committerDuong Do Minh Chau2020-04-16 14:01:12 +0700
commit30199469e124032bef7e0d4c6f67152f4236e3f4 (patch)
tree683cb6c5ed25b21797d1e4dbb45e153ed607ddbb
parent27339ae918168be9bab93636d6a8c598da268c7b (diff)
downloadaur-30199469e124032bef7e0d4c6f67152f4236e3f4.tar.gz
Use Arch font packages
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD12
2 files changed, 14 insertions, 1 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b716e4d61a7d..04723b330901 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -22,6 +22,9 @@ pkgbase = o20-git
depends = kconfig
depends = kiconthemes
depends = kcoreaddons
+ depends = ttf-roboto
+ depends = ttf-roboto-mono
+ depends = ttf-opensans
provides = o20
conflicts = o20
source = o20-git::git+https://gitlab.com/abstractsoftware/o20/o20coreapps.git
diff --git a/PKGBUILD b/PKGBUILD
index 7f6fbdb40975..883b09235232 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,6 +9,7 @@ license=('GPL')
depends=(zlib syntax-highlighting sonnet breeze
qt5-{base,svg,quickcontrols{,2}}
k{textwidgets,widgetsaddons,archive,config,iconthemes,coreaddons}
+ ttf-roboto ttf-roboto-mono ttf-opensans
)
makedepends=(git cmake extra-cmake-modules)
provides=(${pkgname/-git/})
@@ -27,7 +28,7 @@ build() {
# TODO: Use existing font packages instead
cmake \
-DCOMPILE_ONLY_WORD=On \
- -DINSTALL_FONT=On \
+ -DINSTALL_FONT=Off \
..
make
}
@@ -38,4 +39,13 @@ package() {
cd ..
install -Dm644 -t "${pkgdir}/usr/share/licenses/o20" \
COPYING LICENSE
+ cd dev
+ # Some fonts are on AUR, I am still thinking about whether
+ # to put them in dependencies
+ find o20.fonts/Roboto -name 'RobotoSlab*.ttf' -exec \
+ install -Dm644 {} "${pkgdir}/usr/share/fonts/"{} \;
+ find o20.fonts/Ubuntu -name 'Ubuntu*.ttf' -exec \
+ install -Dm644 {} "${pkgdir}/usr/share/fonts/"{} \;
+ find o20.fonts/Lobster -type f -exec \
+ install -Dm644 {} "${pkgdir}/usr/share/fonts/"{} \;
}