summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVincent2015-07-06 01:27:52 +0200
committerVincent2015-07-06 01:27:52 +0200
commita7efe006652b9c7a087c663a696c89fbe4d02d7b (patch)
treec1fd356e2634fa2badb65dbf01f60b4329601cd3
downloadaur-a7efe006652b9c7a087c663a696c89fbe4d02d7b.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD30
-rw-r--r--configure.patch22
3 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fa5ae0a9dbd4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = oacapture
+ pkgdesc = oaCapture is a planetary imaging application in Qt4
+ pkgver = 0.5.0
+ pkgrel = 1
+ url = http://www.openastroproject.org/oacapture/
+ arch = i686
+ arch = x86_64
+ license = GPLv3
+ depends = qt4
+ optdepends = fxload: support for QHY5 cameras
+ source = http://www.openastroproject.org/wp-content/uploads/2015/05/oaCapture-0.5.0.tar.bz2
+ source = configure.patch
+ sha1sums = 07bfbceae008fae97814689a97ead0f7246d8b52
+ sha1sums = bd8f1e136c33a444e92abea2ef8fb74fff7b9008
+
+pkgname = oacapture
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2125f93fd076
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+pkgname=oacapture
+_realname=oaCapture
+pkgver=0.5.0
+pkgrel=1
+pkgdesc="oaCapture is a planetary imaging application in Qt4"
+arch=('i686' 'x86_64')
+license=('GPLv3')
+depends=('qt4')
+url="http://www.openastroproject.org/oacapture/"
+optdepends=('fxload: support for QHY5 cameras')
+
+source=("http://www.openastroproject.org/wp-content/uploads/2015/05/oaCapture-0.5.0.tar.bz2" "configure.patch")
+sha1sums=('07bfbceae008fae97814689a97ead0f7246d8b52' 'bd8f1e136c33a444e92abea2ef8fb74fff7b9008')
+
+build() {
+ cd "${_realname}-${pkgver}"
+ patch -Np1 < ${srcdir}/configure.patch
+ autoreconf --force --install
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "${_realname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+
+ # removing FFMPEG install, it's already linked in static
+ rm -rf ${pkgdir}/usr/include ${pkgdir}/usr/lib
+}
+
diff --git a/configure.patch b/configure.patch
new file mode 100644
index 000000000000..c9583fdc393a
--- /dev/null
+++ b/configure.patch
@@ -0,0 +1,22 @@
+--- oaCapture-0.1.0/configure.ac 2014-11-08 15:24:56.000000000 +0100
++++ /tmp/configure.ac 2015-01-10 01:13:29.877970581 +0100
+@@ -29,8 +29,8 @@
+ if ! `$PKG_CONFIG --atleast-version=4.8.0 QtCore`; then
+ AC_MSG_ERROR([Qt >= 4.8.0 is required.])
+ fi
+-AC_CHECK_PROGS(MOC, [moc-qt5 moc-qt4 moc])
+-AC_CHECK_PROGS(UIC, [uic-qt5 uic-qt4 uic])
++AC_CHECK_PROGS(MOC, [moc-qt4])
++AC_CHECK_PROGS(UIC, [uic-qt4])
+ AC_CHECK_PROGS(RCC, [rcc])
+ if test -z "$MOC" || test -z "$UIC" || test -z "$RCC"; then
+ AC_MSG_ERROR([Qt utility programs moc, uic, and rcc are required.])
+@@ -104,7 +104,7 @@
+
+ FFMPEG_LIBS="\$(top_builddir)/ext/ffmpeg/libavformat/libavformat.a \
+ \$(top_builddir)/ext/ffmpeg/libavcodec/libavcodec.a \
+- \$(top_builddir)/ext/ffmpeg/libavutil/libavutil.a"
++ \$(top_builddir)/ext/ffmpeg/libavutil/libavutil.a -lva"
+
+ AC_ARG_WITH(ffmpeg-extra-configure,
+ AC_HELP_STRING([--with-ffmpeg-extra-configure="xxx"],