summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarc-Olivier Barre2021-01-20 11:07:44 +0100
committerMarc-Olivier Barre2021-01-20 12:51:15 +0100
commit0894e8bc463c275f1a51f93ae2a6cf494bf7676b (patch)
tree17542cec03bc47a2a006e2fcaa56f10be073fdbc
parentba7a3c784c0e35fce491a4f2cc33307be0298b52 (diff)
downloadaur-oacapture-git.tar.gz
Make this into a generic git package
Add missing patches
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD20
-rw-r--r--libhidapi-configure-ac.diff11
-rw-r--r--oacapture-slash-lib.diff11
4 files changed, 46 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4d3235905e8e..9cbfa5ef0179 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = oacapture-git
pkgdesc = A planetary imaging application using Qt5
- pkgver = bb7f8e6
+ pkgver = v1.8.0.1098.adef9b5b
pkgrel = 1
url = http://www.openastroproject.org/oacapture/
arch = i686
@@ -13,10 +13,15 @@ pkgbase = oacapture-git
depends = sdl
depends = libdc1394
optdepends = fxload: support for QHY5 cameras
- provides = oacapture
- conflicts = oacapture
- source = openastro-bb7f8e6::git+https://github.com/openastroproject/openastro#commit=bb7f8e6
+ provides = openastro=v1.8.0.1098.adef9b5b
+ conflicts = openastro
+ replaces = openastro
+ source = git+https://github.com/openastroproject/openastro.git
+ source = oacapture-slash-lib.diff
+ source = libhidapi-configure-ac.diff
sha256sums = SKIP
+ sha256sums = 813e80ef718e0e9887c5293ef435b1cff43d03ae8c2bb6a2d53f0bbbf4a284f2
+ sha256sums = 204c6d6dea820fa9564026df4d0bd15d866bd9904d0afd3e51c3fd7ddf69a844
pkgname = oacapture-git
diff --git a/PKGBUILD b/PKGBUILD
index 23917bfd1311..2b13bc0f77d7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,6 @@
pkgname=oacapture-git
-pkgver=bb7f8e6
+_gitname=openastro
+pkgver=v1.8.0.1098.adef9b5b
pkgrel=1
pkgdesc="A planetary imaging application using Qt5"
provides=("oacapture")
@@ -9,19 +10,28 @@ license=('GPLv3')
depends=('qt5-base' 'qt5-tools' 'cfitsio' 'autoconf-archive' 'sdl' 'libdc1394')
url="http://www.openastroproject.org/oacapture/"
optdepends=('fxload: support for QHY5 cameras')
+source=("git+https://github.com/openastroproject/openastro.git" "oacapture-slash-lib.diff" "libhidapi-configure-ac.diff")
+sha256sums=("SKIP" "813e80ef718e0e9887c5293ef435b1cff43d03ae8c2bb6a2d53f0bbbf4a284f2" "204c6d6dea820fa9564026df4d0bd15d866bd9904d0afd3e51c3fd7ddf69a844")
+provides=($_gitname=$pkgver)
+conflicts=($_gitname)
+replaces=($_gitname)
-source=("openastro-$pkgver::git+https://github.com/openastroproject/openastro#commit=${pkgver}")
-sha256sums=("SKIP")
+pkgver() {
+ cd "${srcdir}/${_gitname}"
+ printf "%s.%s.%s" "$(git describe --tags | cut -d "-" -f1)" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
build() {
- cd "openastro-${pkgver}"
+ cd "openastro"
+ patch -Np1 < ${srcdir}/oacapture-slash-lib.diff
+ patch -Np1 < ${srcdir}/libhidapi-configure-ac.diff
./bootstrap
./configure --prefix=/usr
make
}
package() {
- cd "openastro-${pkgver}"
+ cd "openastro"
make DESTDIR="${pkgdir}" install
# remove unwanted files
diff --git a/libhidapi-configure-ac.diff b/libhidapi-configure-ac.diff
new file mode 100644
index 000000000000..98c6765f2687
--- /dev/null
+++ b/libhidapi-configure-ac.diff
@@ -0,0 +1,11 @@
+diff -ru a/ext/libhidapi/configure.ac b/ext/libhidapi/configure.ac
+--- a/ext/libhidapi/configure.ac 2020-12-08 11:58:13.000000000 +0100
++++ b/ext/libhidapi/configure.ac 2021-01-19 18:31:21.034233203 +0100
+@@ -18,7 +18,6 @@
+ lt_age="0"
+ LTLDFLAGS="-version-info ${lt_current}:${lt_revision}:${lt_age}"
+
+-AC_CONFIG_MACRO_DIR([m4])
+ AM_INIT_AUTOMAKE([foreign -Wall -Werror])
+ AC_CONFIG_MACRO_DIR([m4])
+
diff --git a/oacapture-slash-lib.diff b/oacapture-slash-lib.diff
new file mode 100644
index 000000000000..c1aea55306a1
--- /dev/null
+++ b/oacapture-slash-lib.diff
@@ -0,0 +1,11 @@
+diff --git a/udev/Makefile.am b/udev/Makefile.am
+index 8b7d790..e5e58ce 100644
+--- a/udev/Makefile.am
++++ b/udev/Makefile.am
+@@ -31,5 +31,5 @@ RULESFILES = 70-altair-cameras.rules 70-atik.rules 70-celestron-camera.rules \
+ 70-tis-cameras.rules 70-tis-cameras-uvc.rules \
+ 70-touptek-cameras.rules 70-xagyl-ftdi.rules 85-qhy-cameras.rules
+
+-udevrulesdir = ${sysconfdir}/../lib/udev/rules.d
++udevrulesdir = ${sysconfdir}/../usr/lib/udev/rules.d
+ udevrules_DATA = $(RULESFILES)