summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBen Oliver2021-03-09 19:58:06 +0000
committerBen Oliver2021-03-09 19:58:06 +0000
commit0fd4c0a1b7e5a715774cea0e778c48f214c0e46b (patch)
tree4a9da201a8fd0cabc40784738a772ceaee0f07ad
parent7c2cdf2ef03ded01ac8a0e6e6effe650f701da4f (diff)
downloadaur-0fd4c0a1b7e5a715774cea0e778c48f214c0e46b.tar.gz
install systemd unit
-rw-r--r--PKGBUILD14
-rw-r--r--oasis.install5
2 files changed, 15 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0c0b3887d51e..8251b557152d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Ben Oliver <ben@bfoliver.com>
pkgname=oasis
-pkgrel=1
+pkgrel=2
pkgver=2.17.0
pkgdesc="Helps you follow friends and discover new ones on Secure Scuttlebutt (SSB)."
arch=('any')
@@ -8,8 +8,12 @@ url='https://github.com/fraction/oasis'
license=('AGPL3')
makedepends=('npm')
noextract=("${pkgname}-${pkgver}.tgz")
-source=("https://github.com/fraction/${pkgname}/archive/v${pkgver}.tar.gz")
-md5sums=('25ffb6dbc852c1f2ded2c24ce333c352')
+source=(https://github.com/fraction/${pkgname}/archive/v${pkgver}.tar.gz
+ oasis.install
+)
+install=oasis.install
+md5sums=('25ffb6dbc852c1f2ded2c24ce333c352'
+ '530a21b91ca2d7340ede2fd91fc3dbeb')
package() {
npm install -g --prefix "${pkgdir}/usr" "${srcdir}/v${pkgver}.tar.gz"
@@ -17,5 +21,7 @@ package() {
find "${pkgdir}/usr" -type d -exec chmod 755 {} +
chown -R root:root "${pkgdir}"
-}
+ install -Dm644 "${srcdir}"/${pkgname}-${pkgver}/contrib/${pkgname}.service \
+ "${pkgdir}"/usr/lib/systemd/user/${pkgname}.service
+}
diff --git a/oasis.install b/oasis.install
new file mode 100644
index 000000000000..7515d5acc025
--- /dev/null
+++ b/oasis.install
@@ -0,0 +1,5 @@
+post_install() {
+ echo 'A systemd service file is available, run:'
+ echo 'systemctl --user start oasis'
+ echo 'It can be accessed on http://localhost:4515'
+}