summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBen Oliver2021-03-09 18:08:20 +0000
committerBen Oliver2021-03-09 18:08:20 +0000
commit7c2cdf2ef03ded01ac8a0e6e6effe650f701da4f (patch)
treec958fdeac7cde2d95f880eaef374003aee6d4084
downloadaur-7c2cdf2ef03ded01ac8a0e6e6effe650f701da4f.tar.gz
Initial Commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD21
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..58748fd64888
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = oasis
+ pkgdesc = Helps you follow friends and discover new ones on Secure Scuttlebutt (SSB).
+ pkgver = 2.17.0
+ pkgrel = 1
+ url = https://github.com/fraction/oasis
+ arch = any
+ license = AGPL3
+ makedepends = npm
+ noextract = oasis-2.17.0.tgz
+ source = https://github.com/fraction/oasis/archive/v2.17.0.tar.gz
+ md5sums = 25ffb6dbc852c1f2ded2c24ce333c352
+
+pkgname = oasis
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0c0b3887d51e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Ben Oliver <ben@bfoliver.com>
+pkgname=oasis
+pkgrel=1
+pkgver=2.17.0
+pkgdesc="Helps you follow friends and discover new ones on Secure Scuttlebutt (SSB)."
+arch=('any')
+url='https://github.com/fraction/oasis'
+license=('AGPL3')
+makedepends=('npm')
+noextract=("${pkgname}-${pkgver}.tgz")
+source=("https://github.com/fraction/${pkgname}/archive/v${pkgver}.tar.gz")
+md5sums=('25ffb6dbc852c1f2ded2c24ce333c352')
+
+package() {
+ npm install -g --prefix "${pkgdir}/usr" "${srcdir}/v${pkgver}.tar.gz"
+
+ find "${pkgdir}/usr" -type d -exec chmod 755 {} +
+
+ chown -R root:root "${pkgdir}"
+}
+