summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortrizen2015-06-17 13:24:58 +0300
committertrizen2015-06-17 13:24:58 +0300
commitf9ef6f4e50b1c8603efad8700a7b748f34b6d94a (patch)
treea9093d45ae44ef16b69f0d8c46731aa020468f60
downloadaur-f9ef6f4e50b1c8603efad8700a7b748f34b6d94a.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD21
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4468faa2b5fa
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = obbrowser
+ pkgdesc = Recursively browse the filesystem through openbox3 pipe menus. (with icons)
+ pkgver = 0.05
+ pkgrel = 1
+ url = http://trizenx.blogspot.ro/2012/12/obbrowser.html
+ arch = any
+ license = GPLv3
+ depends = perl>=5.14.0
+ depends = perl-data-dump
+ depends = perl-linux-desktopfiles>=0.08
+ depends = perl-file-mimeinfo
+ source = https://github.com/trizen/obbrowser/archive/0.05.tar.gz
+ sha256sums = aecab19c197aebb66417433ec96f7e2e9a1387a4720d39547854b609da5af3d4
+
+pkgname = obbrowser
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e7eea701ce81
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Trizen <echo dHJpemVueEBnbWFpbC5jb20K | base64 -d>
+
+pkgname=obbrowser
+pkgver=0.05
+pkgrel=1
+
+pkgdesc="Recursively browse the filesystem through openbox3 pipe menus. (with icons)"
+url="http://trizenx.blogspot.ro/2012/12/obbrowser.html"
+
+arch=('any')
+license=('GPLv3')
+
+depends=('perl>=5.14.0' 'perl-data-dump' 'perl-linux-desktopfiles>=0.08' 'perl-file-mimeinfo')
+source="https://github.com/trizen/${pkgname}/archive/${pkgver}.tar.gz"
+sha256sums=('aecab19c197aebb66417433ec96f7e2e9a1387a4720d39547854b609da5af3d4')
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -Dm755 "$pkgname" "$pkgdir/usr/bin/$pkgname"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}