summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJerome Leclanche2015-06-09 22:03:28 +0200
committerJerome Leclanche2015-06-09 22:03:28 +0200
commitbea1477374f1ef393015bc2fc86a4ea888062fa3 (patch)
tree124ce04f52e2c4ef7dd8a5a709f26cc4186f8506
downloadaur-bea1477374f1ef393015bc2fc86a4ea888062fa3.tar.gz
Initial import from old AUR
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD35
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..da5ac2427bc7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = obconf-qt-git
+ pkgdesc = Openbox configuration tool. Qt port of ObConf
+ pkgver = 0.1.0.18.gfe11967
+ pkgrel = 1
+ url = http://lxqt.org
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = git
+ makedepends = cmake
+ makedepends = qt5-tools
+ depends = qt5-base
+ provides = obconf-qt
+ conflicts = obconf-qt
+ source = git+https://github.com/lxde/obconf-qt.git
+ sha256sums = SKIP
+
+pkgname = obconf-qt-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4b3dbe190290
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Jerome Leclanche <jerome@leclan.ch>
+
+_pkgname=obconf-qt
+pkgname=$_pkgname-git
+pkgver=0.1.0.18.gfe11967
+pkgrel=1
+pkgdesc="Openbox configuration tool. Qt port of ObConf"
+arch=("i686" "x86_64")
+url="http://lxqt.org"
+license=("GPL2")
+depends=("qt5-base")
+makedepends=("git" "cmake" "qt5-tools")
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=("git+https://github.com/lxde/$_pkgname.git")
+sha256sums=("SKIP")
+
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ git describe --always | sed "s/-/./g"
+}
+
+build() {
+ mkdir -p build
+ cd build
+ cmake "$srcdir/$_pkgname" \
+ -DCMAKE_INSTALL_PREFIX=/usr
+ make
+}
+
+package() {
+ cd build
+ make DESTDIR="$pkgdir" install
+}