summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBartłomiej Piotrowski2018-01-06 22:04:08 +0100
committerBartłomiej Piotrowski2018-01-06 22:04:08 +0100
commita740c32e940c40966c43ae899e128ada4f820f57 (patch)
tree0eaafc40a33c4ff98319091b3e9ae216e9216d8c
downloadaur-a740c32e940c40966c43ae899e128ada4f820f57.tar.gz
Import from official repositories
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD29
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6552c427ecb6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = obexfs
+ pkgdesc = FUSE based filesystem using ObexFTP (currently beta).
+ pkgver = 0.12
+ pkgrel = 4
+ url = http://openobex.triq.net/obexfs
+ arch = x86_64
+ license = GPL
+ depends = fuse2
+ depends = obexftp>=0.22
+ source = http://triq.net/obexftp/obexfs-0.12.tar.gz
+ md5sums = 0f505672b025cdb505e215ee707a2e2f
+
+pkgname = obexfs
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a22d46c8a4fd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# $Id: PKGBUILD 266875 2017-11-15 14:29:11Z foutrelis $
+# Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
+# Packager: cs-cam - me.at.camdaniel.com
+
+pkgname=obexfs
+pkgver=0.12
+pkgrel=4
+pkgdesc="FUSE based filesystem using ObexFTP (currently beta)."
+arch=('x86_64')
+url="http://openobex.triq.net/obexfs"
+license=('GPL')
+source=(http://triq.net/obexftp/$pkgname-$pkgver.tar.gz)
+depends=('fuse2' 'obexftp>=0.22')
+md5sums=('0f505672b025cdb505e215ee707a2e2f')
+
+build() {
+ cd "$srcdir"/$pkgname-$pkgver
+
+ export OBEXFTP_CFLAGS="-I/usr/include/obexftp -I/usr/include/multicobex -I/usr/include/bfb"
+ export OBEXFTP_LIBS="-lobexftp -lmulticobex -lbfb -lopenobex -lbluetooth"
+
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir"/$pkgname-$pkgver
+ make DESTDIR="$pkgdir" install
+}