summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLibre Liu2020-02-07 02:48:18 +0800
committerLibre Liu2020-02-07 02:48:18 +0800
commite68639d9de2034e8b1d30237cc72e64b3674964d (patch)
tree854a06a890230c3ff29738ab2bffeb5e612a6267
downloadaur-e68639d9de2034e8b1d30237cc72e64b3674964d.tar.gz
First packaged version. TODO: Add desktop entries
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD54
2 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a28280c224d1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = objgui-git
+ pkgdesc = ObjGui is a GUI disassembler and binary analysis tool utilizing GNU binutils.
+ pkgver = r120.56beadc
+ pkgrel = 1
+ url = https://github.com/jubal-R/ObjGui
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ depends = qt5-base
+ provides = objgui
+ conflicts = objgui
+ source = objgui::git+https://github.com/jubal-R/ObjGui
+ md5sums = SKIP
+
+pkgname = objgui-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..137fdece6dc6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,54 @@
+# Maintainer: Libre Liu <libreliu@foxmail.com>
+
+pkgname=objgui-git
+pkgver=r120.56beadc
+pkgrel=1
+pkgdesc="ObjGui is a GUI disassembler and binary analysis tool utilizing GNU binutils. "
+arch=('x86_64')
+url="https://github.com/jubal-R/ObjGui"
+license=('GPL')
+groups=()
+depends=('qt5-base')
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+replaces=()
+backup=()
+options=()
+install=
+source=('objgui::git+https://github.com/jubal-R/ObjGui')
+noextract=()
+md5sums=('SKIP')
+
+# Please refer to the 'USING git SOURCES' section of the PKGBUILD man page for
+# a description of each element in the source array.
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+
+# Git, no tags available
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+
+}
+
+prepare() {
+ true
+}
+
+build() {
+ cd "$srcdir/${pkgname%-git}"
+ rm -r build || true
+ mkdir build
+ cd build
+ qmake ../src/ObjGui.pro
+ make
+}
+
+check() {
+ true
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}/build"
+ install -D -m755 ObjGui "$pkgdir"/usr/bin/ObjGui
+}