summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric Anderson2015-11-15 18:35:08 -0800
committerEric Anderson2015-11-15 18:35:08 -0800
commit227041894a6bd133975b8c7f9ced07aaf5c8e036 (patch)
treedd81cc9430a1b362cbec98690907093002f6010e
parentb895fc55a481a2cc5b62fff91133ac7974665b0c (diff)
downloadaur-227041894a6bd133975b8c7f9ced07aaf5c8e036.tar.gz
Patch compatibility issue with Paramiko 1.16
-rw-r--r--.SRCINFO2
-rw-r--r--Add-prefetch-size-argument.patch31
-rw-r--r--PKGBUILD9
3 files changed, 39 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e1a7f0e784f9..71fdb01ee7a3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -14,7 +14,9 @@ pkgbase = obnam
depends = python2-yaml
optdepends = python2-fuse: support for mounting backups
source = http://code.liw.fi/debian/pool/main/o/obnam/obnam_1.18.1.orig.tar.xz
+ source = Add-prefetch-size-argument.patch
sha256sums = 455159a162ce6cddbe7dacc04f94ba3cd9e65c868ea41d3f06b44254da523c7e
+ sha256sums = f1504e89c6e003cdf40cfbdc5154dafd3f7fd41aa19c4cab7120486c241d5e32
pkgname = obnam
diff --git a/Add-prefetch-size-argument.patch b/Add-prefetch-size-argument.patch
new file mode 100644
index 000000000000..20a8e7cb6b78
--- /dev/null
+++ b/Add-prefetch-size-argument.patch
@@ -0,0 +1,31 @@
+From 738e9291ed15980bdac568fc5f9507a43897ba52 Mon Sep 17 00:00:00 2001
+From: Kyle Manna <kyle@kylemanna.com>
+Date: Fri, 6 Nov 2015 08:12:50 -0800
+Subject: [PATCH] obnamlib: sftp: Add prefetch size argument
+
+Paramiko made this argument required in v1.16. Details at
+https://github.com/paramiko/paramiko/commit/49072f3537a8981e9d448c22481a1d2b92c03643
+
+Attempt to fetch the entire file. I'm unsure if this is the original
+intent. If the entire file isn't to be fetched, then the prefetch() is
+probably not needed.
+---
+ obnamlib/plugins/sftp_plugin.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/obnamlib/plugins/sftp_plugin.py b/obnamlib/plugins/sftp_plugin.py
+index c4d5c2f..a5bc72b 100644
+--- a/obnamlib/plugins/sftp_plugin.py
++++ b/obnamlib/plugins/sftp_plugin.py
+@@ -555,7 +555,7 @@ class SftpFS(obnamlib.VirtualFileSystem):
+ def cat(self, pathname):
+ self._delay()
+ f = self.open(pathname, 'rb')
+- f.prefetch()
++ f.prefetch(self.lstat(pathname).st_size)
+ chunks = []
+ while True:
+ chunk = f.read(self.chunk_size)
+--
+2.6.2
+
diff --git a/PKGBUILD b/PKGBUILD
index 3461a33512e7..ea4c663a54f3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=obnam
pkgver=1.18.1
-pkgrel=1
+pkgrel=2
pkgdesc="Easy, secure backup program"
arch=('i686' 'x86_64')
url="http://obnam.org/"
@@ -11,12 +11,15 @@ license=('GPL3')
depends=('python2-paramiko' 'python2-tracing' 'python2-larch'
'python2-ttystatus' 'python2-cliapp' 'python2-yaml')
optdepends=('python2-fuse: support for mounting backups')
-source=("http://code.liw.fi/debian/pool/main/o/obnam/obnam_$pkgver.orig.tar.xz")
-sha256sums=('455159a162ce6cddbe7dacc04f94ba3cd9e65c868ea41d3f06b44254da523c7e')
+source=("http://code.liw.fi/debian/pool/main/o/obnam/obnam_$pkgver.orig.tar.xz"
+ 'Add-prefetch-size-argument.patch')
+sha256sums=('455159a162ce6cddbe7dacc04f94ba3cd9e65c868ea41d3f06b44254da523c7e'
+ 'f1504e89c6e003cdf40cfbdc5154dafd3f7fd41aa19c4cab7120486c241d5e32')
build() {
cd "$srcdir/$pkgname-$pkgver"
sed -i -e 's/python/python2/' setup.py
+ patch -p1 < "$srcdir/Add-prefetch-size-argument.patch"
python2 setup.py build
}