summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric Anderson2016-01-17 16:25:33 -0800
committerEric Anderson2016-01-17 16:25:33 -0800
commit27a03952ccc156c688aba58414c89c51074fae2e (patch)
tree0575e0dcba2a7e74e8b66a37111c4d738d4afa8a
parent2d544d6fe47698db669e4f33673bb333f9a7d29f (diff)
downloadaur-27a03952ccc156c688aba58414c89c51074fae2e.tar.gz
Update to 1.19
-rw-r--r--.SRCINFO10
-rw-r--r--Add-prefetch-size-argument.patch31
-rw-r--r--PKGBUILD9
3 files changed, 8 insertions, 42 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 211ac6433cf5..b234945a22b4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,8 @@
+# Generated by mksrcinfo v8
+# Mon Jan 18 00:25:08 UTC 2016
pkgbase = obnam
pkgdesc = Easy, secure backup program
- pkgver = 1.18.2
+ pkgver = 1.19
pkgrel = 1
url = http://obnam.org/
arch = i686
@@ -13,10 +15,8 @@ pkgbase = obnam
depends = python2-cliapp
depends = python2-yaml
optdepends = python2-fuse: support for mounting backups
- source = http://code.liw.fi/debian/pool/main/o/obnam/obnam_1.18.2.orig.tar.xz
- source = Add-prefetch-size-argument.patch
- sha256sums = cb5ebfb8d7d71a203e26b49c920cd8e017018d3df44ead454f095b7a4e93b7a0
- sha256sums = f1504e89c6e003cdf40cfbdc5154dafd3f7fd41aa19c4cab7120486c241d5e32
+ source = http://code.liw.fi/debian/pool/main/o/obnam/obnam_1.19.orig.tar.xz
+ sha256sums = 597516692831f273fabfebfa61bdf1ba20832bc168ddc90d22aa3d88eb702195
pkgname = obnam
diff --git a/Add-prefetch-size-argument.patch b/Add-prefetch-size-argument.patch
deleted file mode 100644
index 20a8e7cb6b78..000000000000
--- a/Add-prefetch-size-argument.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-From 738e9291ed15980bdac568fc5f9507a43897ba52 Mon Sep 17 00:00:00 2001
-From: Kyle Manna <kyle@kylemanna.com>
-Date: Fri, 6 Nov 2015 08:12:50 -0800
-Subject: [PATCH] obnamlib: sftp: Add prefetch size argument
-
-Paramiko made this argument required in v1.16. Details at
-https://github.com/paramiko/paramiko/commit/49072f3537a8981e9d448c22481a1d2b92c03643
-
-Attempt to fetch the entire file. I'm unsure if this is the original
-intent. If the entire file isn't to be fetched, then the prefetch() is
-probably not needed.
----
- obnamlib/plugins/sftp_plugin.py | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/obnamlib/plugins/sftp_plugin.py b/obnamlib/plugins/sftp_plugin.py
-index c4d5c2f..a5bc72b 100644
---- a/obnamlib/plugins/sftp_plugin.py
-+++ b/obnamlib/plugins/sftp_plugin.py
-@@ -555,7 +555,7 @@ class SftpFS(obnamlib.VirtualFileSystem):
- def cat(self, pathname):
- self._delay()
- f = self.open(pathname, 'rb')
-- f.prefetch()
-+ f.prefetch(self.lstat(pathname).st_size)
- chunks = []
- while True:
- chunk = f.read(self.chunk_size)
---
-2.6.2
-
diff --git a/PKGBUILD b/PKGBUILD
index a95542f6dc59..2275abe7344c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Maintainer: Eric Anderson <ejona86@gmail.com>
pkgname=obnam
-pkgver=1.18.2
+pkgver=1.19
pkgrel=1
pkgdesc="Easy, secure backup program"
arch=('i686' 'x86_64')
@@ -11,15 +11,12 @@ license=('GPL3')
depends=('python2-paramiko' 'python2-tracing' 'python2-larch'
'python2-ttystatus' 'python2-cliapp' 'python2-yaml')
optdepends=('python2-fuse: support for mounting backups')
-source=("http://code.liw.fi/debian/pool/main/o/obnam/obnam_$pkgver.orig.tar.xz"
- 'Add-prefetch-size-argument.patch')
-sha256sums=('cb5ebfb8d7d71a203e26b49c920cd8e017018d3df44ead454f095b7a4e93b7a0'
- 'f1504e89c6e003cdf40cfbdc5154dafd3f7fd41aa19c4cab7120486c241d5e32')
+source=("http://code.liw.fi/debian/pool/main/o/obnam/obnam_$pkgver.orig.tar.xz")
+sha256sums=('597516692831f273fabfebfa61bdf1ba20832bc168ddc90d22aa3d88eb702195')
build() {
cd "$srcdir/$pkgname-$pkgver"
sed -i -e 's/python/python2/' setup.py
- patch -p1 < "$srcdir/Add-prefetch-size-argument.patch"
python2 setup.py build
}