summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric Anderson2015-06-20 09:13:38 -0700
committerEric Anderson2015-06-20 09:13:38 -0700
commitaa279a76dedf2ed2a8877791ddf5281e9bdb3766 (patch)
treed76566710d0535ae9f712eee14d43532d396ae08
downloadaur-aa279a76dedf2ed2a8877791ddf5281e9bdb3766.tar.gz
Initial import
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD26
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..97c9ae34b3df
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = obnam
+ pkgdesc = Easy, secure backup program
+ pkgver = 1.9
+ pkgrel = 1
+ url = http://obnam.org/
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ depends = python2-paramiko
+ depends = python2-tracing
+ depends = python2-larch
+ depends = python2-ttystatus
+ depends = python2-cliapp
+ depends = python2-yaml
+ optdepends = python2-fuse: support for mounting backups
+ source = http://code.liw.fi/debian/pool/main/o/obnam/obnam_1.9.orig.tar.gz
+ sha256sums = e5dc38fd0b923438153f4f983e517b80269129fdb011c8d7900c76076b1f916a
+
+pkgname = obnam
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f0436b23d0b2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Contributor: Mathieu Clabaut <mathieu.clabaut@gmail.com>
+# Maintainer: Eric Anderson <ejona86@gmail.com>
+
+pkgname=obnam
+pkgver=1.9
+pkgrel=1
+pkgdesc="Easy, secure backup program"
+arch=('i686' 'x86_64')
+url="http://obnam.org/"
+license=('GPL3')
+depends=('python2-paramiko' 'python2-tracing' 'python2-larch'
+ 'python2-ttystatus' 'python2-cliapp' 'python2-yaml')
+optdepends=('python2-fuse: support for mounting backups')
+source=("http://code.liw.fi/debian/pool/main/o/obnam/obnam_$pkgver.orig.tar.gz")
+sha256sums=('e5dc38fd0b923438153f4f983e517b80269129fdb011c8d7900c76076b1f916a')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ sed -i -e 's/python/python2/' setup.py
+ python2 setup.py build
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python2 setup.py install --root="$pkgdir" --optimize=1 --skip-build
+}