summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArtem Vorotnikov2015-08-28 23:41:33 +0300
committerArtem Vorotnikov2015-08-28 23:41:33 +0300
commit8f1299ca2db5a7994c23e55d903f17c530b72d8b (patch)
treee69799889472d4a1ecbc44aad9dd8ea6f985f03a
downloadaur-8f1299ca2db5a7994c23e55d903f17c530b72d8b.tar.gz
Initial import
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD29
-rw-r--r--obozrenie.install12
3 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..898a4bfcae85
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = obozrenie-git
+ pkgdesc = Simple and easy to use game server browser
+ pkgver = 0.1
+ pkgrel = 1
+ url = http://github.com/obozrenie
+ install = obozrenie.install
+ arch = any
+ license = GPL3
+ makedepends = git
+ makedepends = python-setuptools
+ depends = desktop-file-utils
+ depends = glib-networking
+ depends = gvfs
+ depends = hicolor-icon-theme
+ depends = python-gobject
+ depends = python-xdg
+ depends = python-pytoml
+ depends = qstat
+ optdepends = python-pygeoip: for geolocation support
+ provides = obozrenie
+ conflicts = obozrenie
+ source = git+https://github.com/obozrenie/obozrenie.git
+ sha256sums = SKIP
+
+pkgname = obozrenie-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d2035b2f6532
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+pkgname=obozrenie-git
+pkgver=0.1
+pkgrel=1
+pkgdesc='Simple and easy to use game server browser'
+arch=('any')
+url='http://github.com/obozrenie'
+license=('GPL3')
+depends=('desktop-file-utils' 'glib-networking' 'gvfs' 'hicolor-icon-theme'
+ 'python-gobject' 'python-xdg' 'python-pytoml' 'qstat')
+makedepends=('git' 'python-setuptools')
+optdepends=('python-pygeoip: for geolocation support')
+provides=('obozrenie')
+conflicts=('obozrenie')
+install='obozrenie.install'
+source=('git+https://github.com/obozrenie/obozrenie.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd obozrenie
+
+ printf "%s" "$(git describe | sed 's/v//; s/-/.r/; s/-g/./')"
+}
+
+package() {
+ cd obozrenie
+
+ python setup.py install --root="${pkgdir}" --optimize='1'
+ install -Dm755 obozrenie-gtk ${pkgdir}/usr/bin/obozrenie-gtk
+}
diff --git a/obozrenie.install b/obozrenie.install
new file mode 100644
index 000000000000..82a3d6766ea1
--- /dev/null
+++ b/obozrenie.install
@@ -0,0 +1,12 @@
+post_install() {
+ gtk-update-icon-cache -ftq usr/share/icons/hicolor
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}