summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortytan6522023-05-18 12:05:44 +0200
committertytan6522023-05-18 12:05:44 +0200
commitc2ccfd1b125dca88593583d5bc9dff77a0c7fb9b (patch)
tree44eb41891384a53da0f26ab0926e90a9ad05c03f
parentb65159f6e5b9ffbca8b684025320c9373ca3e19a (diff)
downloadaur-c2ccfd1b125dca88593583d5bc9dff77a0c7fb9b.tar.gz
build: Update to 1.22.0
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD35
2 files changed, 40 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ad65b9e26ba4..42c142c61156 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = obs-advanced-scene-switcher
pkgdesc = An automated scene switcher for OBS Studio
- pkgver = 1.21.1
+ pkgver = 1.22.0
pkgrel = 1
url = https://obsproject.com/forum/resources/advanced-scene-switcher.395/
arch = x86_64
@@ -9,16 +9,29 @@ pkgbase = obs-advanced-scene-switcher
makedepends = cmake
makedepends = git
makedepends = asio
+ makedepends = curl
+ makedepends = libxss
+ makedepends = libxtst
+ makedepends = openvr
makedepends = websocketpp
depends = obs-studio>=28
- depends = libxss
- depends = libxtst
+ depends = alsa-lib
+ depends = gcc-libs
+ depends = glibc
+ depends = jack
+ depends = leptonica
+ depends = libx11
depends = opencv
- depends = openvr
depends = procps
+ depends = qt6-base
+ depends = tesseract
+ optdepends = curl: Remote file access feature
+ optdepends = libxss: X screensaver related features
+ optdepends = libxtst: X key press related features
+ optdepends = openvr: OpenVR features
options = debug
- source = obs-advanced-scene-switcher::git+https://github.com/WarmUpTill/SceneSwitcher.git#tag=1.21.1
- source = obs-websocket::git+https://github.com/obsproject/obs-websocket.git
+ source = obs-advanced-scene-switcher::git+https://github.com/WarmUpTill/SceneSwitcher.git#tag=1.22.0
+ source = libremidi::git+https://github.com/jcelerier/libremidi.git
sha256sums = SKIP
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index a18737324595..497117c8545e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,30 @@
# Maintainer: tytan652 <tytan652@tytanium.xyz>
pkgname=obs-advanced-scene-switcher
-pkgver=1.21.1
+pkgver=1.22.0
pkgrel=1
pkgdesc="An automated scene switcher for OBS Studio"
arch=("x86_64" "aarch64")
url="https://obsproject.com/forum/resources/advanced-scene-switcher.395/"
license=("GPL2")
depends=(
- "obs-studio>=28" "libxss" "libxtst" "opencv" "openvr"
- "procps"
+ "obs-studio>=28" "alsa-lib" "gcc-libs" "glibc" "jack" "leptonica"
+ "libx11" "opencv" "procps" "qt6-base" "tesseract"
+)
+makedepends=(
+ "cmake" "git" "asio" "curl" "libxss" "libxtst"
+ "openvr" "websocketpp"
+)
+optdepends=(
+ "curl: Remote file access feature"
+ "libxss: X screensaver related features"
+ "libxtst: X key press related features"
+ "openvr: OpenVR features"
)
-makedepends=("cmake" "git" "asio" "websocketpp")
options=('debug')
source=(
"$pkgname::git+https://github.com/WarmUpTill/SceneSwitcher.git#tag=$pkgver"
- "obs-websocket::git+https://github.com/obsproject/obs-websocket.git"
+ "libremidi::git+https://github.com/jcelerier/libremidi.git"
)
sha256sums=(
"SKIP"
@@ -25,24 +34,22 @@ sha256sums=(
prepare() {
cd $pkgname
- git config submodule.deps/obs-websocket.url $srcdir/obs-websocket
+ git config submodule.deps/libremidi.url $srcdir/libremidi
git -c protocol.file.allow=always submodule update
}
build() {
- cd $pkgname
-
- cmake -B build \
- -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ cmake -B build -S $pkgname \
+ -DCMAKE_BUILD_TYPE=None \
-DCMAKE_INSTALL_PREFIX='/usr' \
-DCMAKE_INSTALL_LIBDIR=lib \
-DLINUX_PORTABLE=OFF \
- -DQT_VERSION=6
+ -DQT_VERSION=6 \
+ -Wno-dev
- make -C build
+ cmake --build build
}
package() {
- cd $pkgname
- make -C build DESTDIR="$pkgdir/" install
+ DESTDIR="$pkgdir" cmake --install build
}