summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortytan6522021-01-31 18:36:57 +0100
committertytan6522021-01-31 18:36:57 +0100
commit420cd9788de84d7dec73beb06f2f054508863b78 (patch)
treec07642b464de5da717e9ef656e90635de44cb96f
downloadaur-420cd9788de84d7dec73beb06f2f054508863b78.tar.gz
build: add 0.1.0 version
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD33
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cb81695fd267
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = obs-audio-pan-filter
+ pkgdesc = This is a simple plugin to control stereo pan of audio source in OBS Studio
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://github.com/WarmUpTill/SceneSwitcher
+ arch = x86_64
+ license = GPL2
+ makedepends = cmake
+ depends = obs-studio
+ source = obs-audio-pan-filter-0.1.0.tar.gz::https://github.com/norihiro/obs-audio-pan-filter/archive/0.1.0.tar.gz
+ source = obs-studio-26.1.0.tar.gz::https://github.com/obsproject/obs-studio/archive/26.1.0.tar.gz
+ sha256sums = c01c168d2e45250274a38c8c7ab7e409aa9c576432309770e2acc77024f36cdd
+ sha256sums = c015d9bab1075ecf9c66c066328e291a20ef36880958fb3db6486ebc5ca9c6da
+
+pkgname = obs-audio-pan-filter
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..aaca295dd07b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: tytan652 <tytan652@tytanium.xyz>
+_pluginname=SceneSwitcher
+pkgname=obs-audio-pan-filter
+pkgver=0.1.0
+_obsver=26.1.0
+pkgrel=1
+pkgdesc="This is a simple plugin to control stereo pan of audio source in OBS Studio"
+arch=('x86_64')
+url="https://github.com/WarmUpTill/SceneSwitcher"
+license=("GPL2")
+depends=("obs-studio")
+makedepends=("cmake")
+source=(
+ "$pkgname-$pkgver.tar.gz"::"https://github.com/norihiro/$pkgname/archive/$pkgver.tar.gz"
+ "obs-studio-$_obsver.tar.gz::https://github.com/obsproject/obs-studio/archive/$_obsver.tar.gz"
+)
+sha256sums=(
+ 'c01c168d2e45250274a38c8c7ab7e409aa9c576432309770e2acc77024f36cdd'
+ 'c015d9bab1075ecf9c66c066328e291a20ef36880958fb3db6486ebc5ca9c6da'
+)
+
+build() {
+ cd "$pkgname-$pkgver"
+ cmake -B build \
+ -DLIBOBS_INCLUDE_DIR=../obs-studio-$_obsver/libobs \
+ -DCMAKE_INSTALL_PREFIX='/usr'
+ make -C build
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make -C build DESTDIR="$pkgdir/" install
+} \ No newline at end of file