summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortytan6522022-09-01 10:38:22 +0200
committertytan6522022-09-01 10:38:22 +0200
commite2c0b7348311af27b4806827816608340059eddc (patch)
tree9d95e27628cd5a988643c54e4c5e52f17e926fc3
parentdcbcc203766379c8604c18960ee79ff5af2c511f (diff)
downloadaur-e2c0b7348311af27b4806827816608340059eddc.tar.gz
build: Update to 0.3.0
OBS Studio 28 and later is set because of the CMake and Qt changes between 27 and 28
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD14
2 files changed, 14 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index de9a8b9b7046..861874480654 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
pkgbase = obs-audio-pan-filter
pkgdesc = This is a simple plugin to control stereo pan of audio source in OBS Studio
- pkgver = 0.1.2
- pkgrel = 4
+ pkgver = 0.2.2
+ pkgrel = 1
url = https://obsproject.com/forum/resources/audio-pan-filter.1042/
arch = i686
arch = x86_64
arch = aarch64
license = GPL2
makedepends = cmake
- depends = obs-studio<28
+ depends = obs-studio>=28
options = debug
- source = obs-audio-pan-filter-0.1.2.tar.gz::https://github.com/norihiro/obs-audio-pan-filter/archive/0.1.2.tar.gz
- sha256sums = f4a93cf85ea98f13861181e93b4c4f60dffef8a8a1206b214bd3d6f3fdcade79
+ source = obs-audio-pan-filter-0.2.2.tar.gz::https://github.com/norihiro/obs-audio-pan-filter/archive/0.2.2.tar.gz
+ sha256sums = b06ffd8c715bbf9884aea260699c7cb85468200a2413351cc2b52dc38c9d8440
pkgname = obs-audio-pan-filter
diff --git a/PKGBUILD b/PKGBUILD
index 92f3e22d730a..fa49250c3b4f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,27 @@
# Maintainer: tytan652 <tytan652@tytanium.xyz>
pkgname=obs-audio-pan-filter
-pkgver=0.1.2
-pkgrel=4
+pkgver=0.2.2
+pkgrel=1
pkgdesc="This is a simple plugin to control stereo pan of audio source in OBS Studio"
arch=("i686" "x86_64" "aarch64")
url="https://obsproject.com/forum/resources/audio-pan-filter.1042/"
license=("GPL2")
-depends=("obs-studio<28")
+depends=("obs-studio>=28")
makedepends=("cmake")
options=('debug')
source=("$pkgname-$pkgver.tar.gz::https://github.com/norihiro/$pkgname/archive/$pkgver.tar.gz")
-sha256sums=("f4a93cf85ea98f13861181e93b4c4f60dffef8a8a1206b214bd3d6f3fdcade79")
+sha256sums=("b06ffd8c715bbf9884aea260699c7cb85468200a2413351cc2b52dc38c9d8440")
build() {
cd "$pkgname-$pkgver"
cmake -B build \
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
- -DCMAKE_INSTALL_PREFIX='/usr'
+ -DCMAKE_INSTALL_PREFIX='/usr' \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DLINUX_PORTABLE=OFF \
+ -DQT_VERSION=6
+
make -C build
}