summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortytan6522022-02-04 13:03:07 +0100
committertytan6522022-02-04 13:03:07 +0100
commitfbfdda1f766998ff590975fda3277c497bbee65d (patch)
treef866917e207d91308054c69b6b9387b91d1858fb
parent3aa5670be6786876ec561666de70e058cec368fe (diff)
downloadaur-fbfdda1f766998ff590975fda3277c497bbee65d.tar.gz
build: Enable debug symbol
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD4
2 files changed, 5 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 90fed7bafed3..934faa408c10 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = obs-audio-pan-filter
pkgdesc = This is a simple plugin to control stereo pan of audio source in OBS Studio
pkgver = 0.1.2
- pkgrel = 2
+ pkgrel = 3
url = https://obsproject.com/forum/resources/audio-pan-filter.1042/
arch = i686
arch = x86_64
@@ -9,6 +9,7 @@ pkgbase = obs-audio-pan-filter
license = GPL2
makedepends = cmake
depends = obs-studio
+ options = debug
source = obs-audio-pan-filter-0.1.2.tar.gz::https://github.com/norihiro/obs-audio-pan-filter/archive/0.1.2.tar.gz
sha256sums = f4a93cf85ea98f13861181e93b4c4f60dffef8a8a1206b214bd3d6f3fdcade79
diff --git a/PKGBUILD b/PKGBUILD
index cde01b615db5..fd6176a00cc2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,19 +2,21 @@
pkgname=obs-audio-pan-filter
pkgver=0.1.2
-pkgrel=2
+pkgrel=3
pkgdesc="This is a simple plugin to control stereo pan of audio source in OBS Studio"
arch=("i686" "x86_64" "aarch64")
url="https://obsproject.com/forum/resources/audio-pan-filter.1042/"
license=("GPL2")
depends=("obs-studio")
makedepends=("cmake")
+options=('debug')
source=("$pkgname-$pkgver.tar.gz::https://github.com/norihiro/$pkgname/archive/$pkgver.tar.gz")
sha256sums=("f4a93cf85ea98f13861181e93b4c4f60dffef8a8a1206b214bd3d6f3fdcade79")
build() {
cd "$pkgname-$pkgver"
cmake -B build \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX='/usr'
make -C build
}