summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNg Oon-Ee2023-04-26 09:51:01 +0800
committerNg Oon-Ee2023-04-26 09:51:01 +0800
commit92edbc584fbec8521f7e3566ae0e7661011944fd (patch)
tree06ae35901bde86eb5b5c80b539c80f4360b2922b
parent177d30e94f74a8a29e61be0695ec3bbb7cc83d4f (diff)
downloadaur-92edbc584fbec8521f7e3566ae0e7661011944fd.tar.gz
Bump version to 0.5.17
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD46
2 files changed, 18 insertions, 39 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 59f718218f38..5e6177f8e3ed 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,14 @@
pkgbase = obs-backgroundremoval
pkgdesc = Background removal plugin for OBS studio (precompiled onnxruntime)
- pkgver = 0.4.0
+ pkgver = 0.5.17
pkgrel = 1
url = https://github.com/royshil/obs-backgroundremoval
arch = x86_64
- license = MIT
- license = custom
+ license = MIT custom
makedepends = cmake
depends = obs-studio
depends = opencv
- source = obs-backgroundremoval-0.4.0.tar.gz::https://github.com/royshil/obs-backgroundremoval/archive/refs/tags/v0.4.0.tar.gz
- source = https://github.com/microsoft/onnxruntime/releases/download/v1.7.0/onnxruntime-linux-x64-1.7.0.tgz
- sha256sums = e88bbc902154b5efd46d8fc1dee52fcf079c8ff2ae6593d9f716017fdd1ef601
- sha256sums = 0345f45f222208344406d79a6db3280ed2ccc884dc1e064ce6e6951ed4c70606
+ source = obs-backgroundremoval-0.5.17.tar.gz::https://github.com/royshil/obs-backgroundremoval/archive/refs/tags/v0.5.17.tar.gz
+ sha256sums = 7e44c352f2b1d082f7904fea4773caadf52cc666e8c64ed954a69a57c31c855b
pkgname = obs-backgroundremoval
diff --git a/PKGBUILD b/PKGBUILD
index 0658942dc396..11c6627acb9f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,46 +1,28 @@
+# Maintainer: Ng Oon-Ee <n g o o n e e dot t a l k @ gmail dot com>
+# Previously contributed by PedroHLC <root@pedrohlc.com>
pkgname=obs-backgroundremoval
-pkgver=0.4.0
+pkgver=0.5.17
pkgrel=1
-_onnx_version=1.7.0
-_onnx_runtime=onnxruntime-linux-x64-${_onnx_version}
-sha256sums=('e88bbc902154b5efd46d8fc1dee52fcf079c8ff2ae6593d9f716017fdd1ef601'
- '0345f45f222208344406d79a6db3280ed2ccc884dc1e064ce6e6951ed4c70606')
+pkgdesc='Background removal plugin for OBS studio (precompiled onnxruntime)'
_source="${pkgname}-${pkgver}"
arch=(x86_64)
url='https://github.com/royshil/obs-backgroundremoval'
-pkgdesc='Background removal plugin for OBS studio (precompiled onnxruntime)'
-license=(MIT custom)
-depends=(obs-studio opencv)
-makedepends=(cmake)
-source=("${_source}.tar.gz::$url/archive/refs/tags/v${pkgver}.tar.gz"
- "https://github.com/microsoft/onnxruntime/releases/download/v${_onnx_version}/${_onnx_runtime}.tgz")
-
-prepare() {
- # build from archive, not git. Version set during build()
- sed -i "s/^version_from_git/#&/" "${_source}/CMakeLists.txt"
-}
+license=('MIT custom')
+depends=('obs-studio' 'opencv')
+makedepends=('cmake')
+source=("${_source}.tar.gz::$url/archive/refs/tags/v${pkgver}.tar.gz")
+sha256sums=('7e44c352f2b1d082f7904fea4773caadf52cc666e8c64ed954a69a57c31c855b')
build() {
cd "$_source"
- # set rpath to avoid installing onnxruntime globally
- cmake -B build -DVERSION="${pkgver}" -DobsIncludePath=/usr/include/obs/ \
- -DCMAKE_INSTALL_PREFIX:PATH=/usr \
- -DOnnxruntime_INCLUDE_DIRS="$srcdir/$_onnx_runtime/include/" -DOnnxruntime_LIBRARIES="$srcdir/$_onnx_runtime/lib/libonnxruntime.so" \
- -DOnnxruntime_INCLUDE_DIR="$srcdir/$_onnx_runtime/include/" \
- -DCMAKE_INSTALL_RPATH="/usr/lib/obs-backgroundremoval"
- cd build
- make
+ cmake -B build -DLINUX_PORTABLE=OFF -DUSE_SYSTEM_OPENCV=ON
+ cmake --build build
}
package() {
- make -C "$_source/build" DESTDIR="$pkgdir" install
- install -Dt "$pkgdir/usr/share/licenses/obs-backgroundremoval" "$_source/LICENSE"
-
- # install onnxruntime
- cd "$_onnx_runtime"
- install -Dt "$pkgdir/usr/share/licenses/obs-backgroundremoval/onnxruntime" \
- LICENSE Privacy.md README.md ThirdPartyNotices.txt
- install -Dt "$pkgdir/usr/lib/obs-backgroundremoval" lib/*
+ cd "$_source"
+ cmake --install build --prefix "$pkgdir/usr"
+ install -Dt "$pkgdir/usr/share/licenses/obs-backgroundremoval" "LICENSE"
}