summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgoreleaserbot2023-08-23 16:36:56 +0000
committergoreleaserbot2023-08-23 16:36:56 +0000
commit15d818a86c21c842678ad2775f4c6fb322964452 (patch)
tree6f3e946e2b8bb0dcee52a94368795368f41148e5
parente4633fa9f70734e2e6a531de95ba8db4ce23051b (diff)
downloadaur-15d818a86c21c842678ad2775f4c6fb322964452.tar.gz
Update to v0.1.6
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD29
2 files changed, 27 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 79fea95b4ab9..3724a6a42189 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,16 @@
pkgbase = obs-bin
- pkgdesc = A placeholder until the pkg has been released via goreleaser
+ pkgdesc = Interact with Obsidian in the terminal. Open, search, create, update and move notes!
pkgver = 0.1.6
pkgrel = 1
url = https://github.com/Yakitrak/obsidian-cli
- arch = any
license = MIT
- provides = ain
- sha256sums = SKIP
-
+ conflicts = obsidian-cli
+ provides = obsidian-cli
+ arch = aarch64
+ source_aarch64 = https://github.com/Yakitrak/obsidian-cli/releases/download/v0.1.6/obsidian-cli_0.1.6_linux_arm64.tar.gz
+ sha256sums_aarch64 = cc52eb27dd8a03bb9b44232c968511bc8475d6e5c96808af8e8b92fdef89a170
+ arch = x86_64
+ source_x86_64 = https://github.com/Yakitrak/obsidian-cli/releases/download/v0.1.6/obsidian-cli_0.1.6_linux_amd64.tar.gz
+ sha256sums_x86_64 = 37c7c9fa2dc2dd115f412bb0cc79ddc8ff203972eebc3a5b22fe3c233c73d3fd
+
pkgname = obs-bin
diff --git a/PKGBUILD b/PKGBUILD
index 0352010babb6..f8f669809064 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,24 @@
+# This file was generated by GoReleaser. DO NOT EDIT.
+# Maintainer: Kartikay Jainwal <kartikayjainwal at gmail dot com>
# Maintainer: Jonathan Neidel <aur at jneidel dot com>
-pkgname=obs-bin
+pkgname='obs-bin'
pkgver=0.1.6
pkgrel=1
-pkgdesc="A placeholder until the pkg has been released via goreleaser"
-arch=(any)
-url="https://github.com/Yakitrak/obsidian-cli"
-license=(MIT)
-depends=()
-makedepends=()
-optdepends=()
-provides=(ain)
-sources=("https://github.com/Yakitrak/obsidian-cli/releases")
-sha256sums=("SKIP")
+pkgdesc='Interact with Obsidian in the terminal. Open, search, create, update and move notes!'
+url='https://github.com/Yakitrak/obsidian-cli'
+arch=('aarch64' 'x86_64')
+license=('MIT')
+provides=('obsidian-cli')
+conflicts=('obsidian-cli')
+
+source_aarch64=("${pkgname}_${pkgver}_aarch64.tar.gz::https://github.com/Yakitrak/obsidian-cli/releases/download/v0.1.6/obsidian-cli_0.1.6_linux_arm64.tar.gz")
+sha256sums_aarch64=('cc52eb27dd8a03bb9b44232c968511bc8475d6e5c96808af8e8b92fdef89a170')
+
+source_x86_64=("${pkgname}_${pkgver}_x86_64.tar.gz::https://github.com/Yakitrak/obsidian-cli/releases/download/v0.1.6/obsidian-cli_0.1.6_linux_amd64.tar.gz")
+sha256sums_x86_64=('37c7c9fa2dc2dd115f412bb0cc79ddc8ff203972eebc3a5b22fe3c233c73d3fd')
package() {
- echo "to be replaced"
+ install -Dm755 "./obs" "${pkgdir}/usr/bin/obs"
+ install -Dm644 "./LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}