summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohannes Dewender2013-04-11 01:39:30 +0200
committerJohannes Dewender2013-04-11 01:39:30 +0200
commitd2e6a687f316179f3295d741a3a2efd027d6a0e1 (patch)
treef626e39a3b797903519e18640a44e8c24898f8e9
parent39b08e8ac70f36353a2bb22625829f1e8209ad95 (diff)
downloadaur-d2e6a687f316179f3295d741a3a2efd027d6a0e1.tar.gz
obs-build-git: update for pacman 4.1
-rw-r--r--.SRCINFO6
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD39
3 files changed, 17 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 22b2cbb1ac6a..931014d574cb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = obs-build-git
pkgdesc = Building part of the OpenSUSE Build Service, osc-build - git version
- pkgver = 20130119
- pkgrel = 2
+ pkgver = 2.0_407.g1eead7d
+ pkgrel = 1
url = http://build.opensuse.org
arch = any
license = GPL
@@ -12,6 +12,8 @@ pkgbase = obs-build-git
depends = xz
provides = obs-build
conflicts = obs-build
+ source = git+https://github.com/openSUSE/obs-build.git
+ md5sums = SKIP
pkgname = obs-build-git
diff --git a/.gitignore b/.gitignore
index bd9b4a41adc0..1e3cea3209ff 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,3 +1,4 @@
+/obs-build
*.tar.gz
*.tar.xz
*.tgz
diff --git a/PKGBUILD b/PKGBUILD
index 9e5453cb357c..25aed25f8b7d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,41 +1,26 @@
+# Contributor: Johannes Dewender arch at JonnyJD dot net
# Contributor: Eduardo Robles Elvira <edulix AT gmail DOT com>
# Contributor: Jon Nordby <jononor@gmail.com>
-# Contributor: Johannes Dewender arch at JonnyJD dot net
-
pkgname=obs-build-git
-_pkgname=obs-build
-provides=($_pkgname)
-conflicts=($_pkgname)
-pkgver=20130119
-pkgrel=2
+pkgver=2.0_407.g1eead7d
+pkgrel=1
pkgdesc="Building part of the OpenSUSE Build Service, osc-build - git version"
url="http://build.opensuse.org"
+arch=(any)
license=("GPL")
depends=(bash perl rpm-org xz)
makedepends=(git)
-arch=(any)
-source=()
-md5sums=()
-
-_gitroot="https://github.com/openSUSE/obs-build.git"
-_gitname="$_pkgname"
-
-build() {
- cd "$srcdir"
- msg "Connecting to GIT server...."
-
- if [ -d $_gitname ] ; then
- cd $_gitname && git pull origin
- msg "The local files are updated."
- else
- git clone $_gitroot $_gitname
- fi
+provides=(obs-build)
+conflicts=(obs-build)
+source=('git+https://github.com/openSUSE/obs-build.git')
+md5sums=('SKIP')
- msg "GIT checkout done or server timeout"
- msg "Install..."
+pkgver() {
+ cd "$srcdir/obs-build"
+ git describe --tags | sed -e 's/obs_//g' -e 's/-/_/' -e 's/-/./g' -e 's/$v//g'
}
package() {
- cd "$srcdir/$_gitname"
+ cd "$srcdir/obs-build"
make install DESTDIR="$pkgdir"
}