summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrederik “Freso” S. Olesen2023-04-05 00:19:32 +0200
committerFrederik “Freso” S. Olesen2023-04-05 00:19:32 +0200
commit25593dcc712986c6555e33c4eb399ca0ea1eabac (patch)
treef2264bd3f559c452b529fa2248adfc83efbbc2d7
downloadaur-25593dcc712986c6555e33c4eb399ca0ea1eabac.tar.gz
Initial obs-captions-plugin-bin PKGBUILD
-rwxr-xr-x.SRCINFO14
-rwxr-xr-xPKGBUILD21
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100755
index 000000000000..c1746e355641
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = obs-captions-plugin-bin
+ pkgdesc = Standalone OBS Studio plugin providing closed captioning via Google Cloud Speech Recognition API
+ pkgver = 0.28
+ pkgrel = 1
+ url = https://github.com/ratwithacompiler/OBS-captions-plugin
+ arch = x86_64
+ license = GPL
+ depends = obs-studio>=28
+ depends = qt6-tools
+ conflicts = obs-captions-plugin
+ source = https://github.com/ratwithacompiler/OBS-captions-plugin/releases/download/v0.28/Closed_Captions_Plugin__v0.28_Linux.zip
+ b2sums = 9e0c312d4b7117bc31afce1a9103b54b566883ab1506196de9803b60e29e7d98bd26e38ff14b137519fa7e249f14f8847c2e80e7c9be4d5b011934cf614ad840
+
+pkgname = obs-captions-plugin-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..a163dba4ac21
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Frederik “Freso” S. Olesen <freso.dk@gmail.com>
+_pkgname=obs-captions-plugin
+_gitname=OBS-captions-plugin
+pkgname=${_pkgname}-bin
+pkgver=0.28
+pkgrel=1
+pkgdesc='Standalone OBS Studio plugin providing closed captioning via Google Cloud Speech Recognition API'
+arch=('x86_64')
+url="https://github.com/ratwithacompiler/${_gitname}"
+license=("GPL")
+conflicts=("${_pkgname}")
+depends=('obs-studio>=28' 'qt6-tools')
+_zipfile="Closed_Captions_Plugin__v${pkgver}_Linux.zip"
+source=("$url/releases/download/v${pkgver}/$_zipfile")
+b2sums=('9e0c312d4b7117bc31afce1a9103b54b566883ab1506196de9803b60e29e7d98bd26e38ff14b137519fa7e249f14f8847c2e80e7c9be4d5b011934cf614ad840')
+
+package() {
+ cd "${_zipfile%.*}"
+ install -Dm644 -t $pkgdir/usr/lib/obs-plugins/ libobs_google_caption_plugin/bin/64bit/libobs_google_caption_plugin.so
+ install -Dm644 -t $pkgdir/usr/share/doc/$_pkgname/ Readme.md
+}