summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDominik Nakamura2023-09-04 20:20:51 +0900
committerDominik Nakamura2023-09-04 20:20:51 +0900
commitf720a16bd0dd1f089fdc07ef2ed6471f4ee75445 (patch)
tree7539c40923c035989b26e8b1cce77e1a92233bd8
parent8182103c15affb95e8ecbeea88ce9d10a739d429 (diff)
downloadaur-f720a16bd0dd1f089fdc07ef2ed6471f4ee75445.tar.gz
upgpkg: obs-composite-blur 1.0.0-2
Simplify packaging by disabling a CMake flag, which caused files to be placed in the wrong location.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD15
2 files changed, 5 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 434fb0917744..6646c5a4d31d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = obs-composite-blur
pkgdesc = Comprehensive blur plugin for OBS that provides several different blur algorithms, and proper compositing
pkgver = 1.0.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/FiniteSingularity/obs-composite-blur
arch = x86_64
license = GPL2
diff --git a/PKGBUILD b/PKGBUILD
index bbe60a925d74..8f81989461a9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=obs-composite-blur
pkgver=1.0.0
-pkgrel=1
+pkgrel=2
pkgdesc="Comprehensive blur plugin for OBS that provides several different blur algorithms, and proper compositing"
arch=('x86_64')
url="https://github.com/FiniteSingularity/obs-composite-blur"
@@ -16,18 +16,11 @@ b2sums=('ae2cdd4d650fd44715f8bf20efa96a0c12bb3a498f0566d4238facb468e1b8fb2ba5736
build() {
cmake -B build -S "$pkgbase-$pkgver" \
-DCMAKE_INSTALL_PREFIX="$pkgdir"/usr \
- -DCMAKE_BUILD_TYPE=Release
- cmake --build build
+ -DCMAKE_BUILD_TYPE=Release \
+ -DLINUX_PORTABLE=OFF
+ cmake --build build
}
package() {
cmake --install build
-
- # Remove duplicate shared library
- rm -rf "$pkgdir"/usr/obs-plugins
-
- # Relocate files from /usr/data/ to /usr/share/obs/
- rm -rf "$pkgdir"/usr/share/obs/*
- mv -f "$pkgdir"/usr/data/* "$pkgdir"/usr/share/obs/
- rm -rf "$pkgdir"/usr/data
}